I deleted a file -


under the false impression that I would be able to easily download a new copy of that file.

The file is needed (I believe) for me to be able to run mongodb shell. When I type 'mongo' to the terminal, I get the error:

mongo: error while loading shared libraries: libssl.so.10: cannot open shared object file: No such file or directory

In case this isn't clear, I know that this file is not present because I deleted it myself. I now want to get the file back.

Here's a list of methods I've attempted in order to get this file back:

  • Downloads through apt-get install. Commonly suggested on other threads/forums for problems with this same 'libssl.so.10' file was a package 'libssl1.0.0'. Unfortunately, that package, nor any other package I've seen/downloaded has replaced the file I deleted. [No 'libssl.so.10' file has been created].

  • I've tried to download rpm files (http://rpm.pbone.net/index.php3/stat/3/srodzaj/1/search/libssl.so.10()(64bit)) to install this file. Through the sites I've found that offer these, none have supplied files explicitly for Elementary OS. I don't really understand what to do with these files and am concerned that I could make the problem worse by blindly following.

  • I've attempted to set-up a dual boot on my rather old laptop, to also run elementary OS, then I thought I could copy the file across. While following this guide: (https://elementary.io/docs/installation#verify-your-download), the 'rufus' program froze that laptop at the same point three times in a row. I discontinued my attempts.

  • I explored using 'testdisk' to recover the deleted file. Given that I deleted the file 2 or 3 days ago at this point and I am concerned about removing making the problem far worse, I didn't want to pursue this.

Can anybody suggest an easier/more successful way I could recover this file?

Thank you.

  • Why did you delete it.If it was for any reason I would rename it instead. Never delete important files
    – Suici Doga
    Mar 24, 2016 at 13:21
  • Have you tried my answer.Mark it as answer if it works
    – Suici Doga
    May 17, 2016 at 1:17

1 Answer 1


Run sudo apt-get install --reinstall libssl1.0.0 in the terminal to reinstall the libssl library on system

I recommend before deleting a important file always rename it to YOURFILENAME.old or YOURFILENAME.bak. Then if you have problems you can always rename it back to the original name :)

So next time don't delete important files like that because you could delete something more important which could cause the OS to be unbootable . If you rename instead of deleting you could always rename it back using the Live USB / CD

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.