3

After disabling my second monitor via system settings, I cannot turn it on anymore with that setting. What did work is to enable it with the NVIDIA settings, but after writing that to Xorg I think I totally screwed up the xorg.conf.

When I unplug the second monitor and plug it back in the display comes back. But once I log out and back in the display is black again.

Since I really have almost no idea what I am doing I need help to clean up this Xorg mess.

# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings:  version 361.28  (buildmeister@swio-display-x64-rhel04-04)  Wed Feb  3 16:26:48 PST 2016

# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 361.28  (buildmeister@swio-display-x64-rhel04-04)  Wed Feb  3 16:27:53 PST 2016

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
    Option         "Xinerama" "0"
EndSection

Section "Files"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Eizo EV2736W"
    HorizSync       31.0 - 89.0
    VertRefresh     59.0 - 61.0
    Option         "DPMS"
EndSection

Section "Monitor"
    Identifier     "Monitor1"
    VendorName     "Unknown"
    ModelName      "Eizo S2411W"
    HorizSync       31.0 - 76.0
    VertRefresh     59.0 - 61.0
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce GTX 980"
    BusID          "PCI:5:0:0"
EndSection

Section "Device"
    Identifier     "Device1"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce GTX 980"
    BusID          "PCI:5:0:0"
    Screen          1
EndSection

Section "Screen"

# Removed Option "nvidiaXineramaInfoOrder" "DFP-2"
# Removed Option "metamodes" "nvidia-auto-select +0+0"
# Removed Option "metamodes" "DP-2: nvidia-auto-select +0+0"
# Removed Option "metamodes" "DP-2: nvidia-auto-select +0+0, DVI-I-1: nvidia-auto-select +2560+0"
# Removed Option "metamodes" "DP-2: nvidia-auto-select +0+0, DVI-I-1: 1920x1200 +2560+0"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "Coolbits" "5"
    Option         "Stereo" "0"
    Option         "nvidiaXineramaInfoOrder" "DFP-4"
    Option         "metamodes" "DP-2: nvidia-auto-select +0+0, DVI-I-1: nvidia-auto-select +2560+0"
    Option         "SLI" "Off"
    Option         "MultiGPU" "Off"
    Option         "BaseMosaic" "off"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection

Section "Screen"

# Removed Option "metamodes" "nvidia-auto-select +0+0"
    Identifier     "Screen1"
    Device         "Device1"
    Monitor        "Monitor1"
    DefaultDepth    24
    Option         "Coolbits" "5"
    Option         "Stereo" "0"
    Option         "metamodes" "DVI-I-1: nvidia-auto-select +0+0"
    Option         "SLI" "Off"
    Option         "MultiGPU" "Off"
    Option         "BaseMosaic" "off"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection
1

Okay, apparently I solved the issue myself, so I post this as an answer to my own question, maybe it helps someone with a similar problem.

What I did was to unplug the first monitor, then reboot. Second monitor displayed the OS correctly. Then plugged in the first monitor, which made both displays work. In the system settings changed the order of the displays and hit apply settings. And that survived a log off/in and a restart. So, seems the issue is solved. :)

  • mark this as answer – Suici Doga Jun 21 '16 at 10:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.