I run elementary OS on my laptop and after I did the usual update and upgrade, sudo apt search stopped working. I've been looking everywhere for an answer and nobody seems to have had this problem!

When I type sudo apt search <package> the output is the usual "sorting ..." but it stops at 1% and doesn't say anything.

I've tried so far: apt-get clean, apt-get update, apt-get -f install; but none seem to be helpful.

Funny thing, I am able to search for packages on the Software Center, and apt-get install also works. So, I don't know what could be causing this.

Please, I need your help! I'm at your disposal and willing to try whatever you think will help me get apt search work again!

  • apt-get install works, right? If yes, try doing sudo apt-get install aptitude and then sudo aptitude. See if that works. Mar 9, 2016 at 8:01
  • @MagnusTeekivi but isn't aptitude another package manager? I apologise if I'm wrong in that asumption -I'm still very new to this whole thing, but I'm trying!-; but I would love to be able to just keep using apt. Or at least understand what's the problem behind apt search not working and if there is a way I can fix it! I really apreciate that you took the time to answer! Mar 14, 2016 at 5:30
  • aptitude should be a console graphical frontend to apt-get and co. Mar 14, 2016 at 8:43

1 Answer 1


apt is not really related to the traditional apt-something commands, it's another application. apt search means you started the application apt with the parameter search. As far as I know apt is under active development and most likely unstable in Ubuntu 14.04. To search the cache for packages, you should use apt-cache search.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.