As shown below, it seems that the connection is ok until I type ls. When that happens the system stays on 227 entering active mode for a few minutes and then I get code 425. Here it is:

    williepabon@WP-Pavilion:~$ ftp -4 1085
Connected to
220 ESFtpServer 0.1 ready.
Name ( 
331 User name okay, need password.
230 User logged in, proceed.
Remote system type is UNIX.
Using binary mode to transfer files.
ftp> pwd
257 "/" is current directory.
ftp> ls
227 Entering Active Mode.
425 Cannot open data connection.

I tried using gnome-terminal and the same thing happens. Any ideas? Thanks.

  • Have you tried with passive mode ("ftp -p")?
    – bitseater
    Mar 5 '16 at 18:26
  • Ok. I've added the right answer to help others
    – bitseater
    Mar 5 '16 at 21:19
  • The other solution I found was to open port 1085 in my firewall. After doing that, ftp also worked fine. Thanks for the help. Mar 6 '16 at 1:08
  • Fine, Williams. Added
    – bitseater
    Mar 6 '16 at 2:45
  • Is Elementary straight forward, i can't connect FTP server on my phone
    – dostana
    Jun 25 '20 at 6:08

You must use passive mode

ftp -p4

However, you can also open port 1085 in your firewall.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.