1

After updating and restarting elementary OS Freya hangs on the logo screen. I figured out that the problem cause VMware tools.
I assume that this guide should help fix it: https://kb.vmware.com/selfservice/microsites/search.do?language=en_US&cmd=displayKC&externalId=2050592

But to use it I somehow should boot system with terminal. I tried to boot with live cd (try elementary before install it), mounted system partition, but when I run the config file (/usr/bin/vmware-config-tools.pl), I got an error (system could find libraries and kernel files), and I suppose that this error occurs because I ran the script from the live cd OS.

Any ideas how can I recover it?
(Might actually be a dupe of Freya with kernel 3.19.0-51 fails to boot).

1

There's a known problem with running the Ubuntu 3.19.0-51 kernel under VMWare:

http://ubuntuforums.org/showthread.php?t=2314723

I don't know if this is the problem you're experiencing, but the symptoms are all the same. The current solution is to revert to an earlier kernel.

  • Thank you for the answer, elfstein. I think that I had the same problem. For me there were two options: downgrade the kernel or wait for the vmware tools upgrade. So I picked the first one since everything was working well before the update. – Anton Khaybulaev Feb 26 '16 at 23:12
  • You're welcome. After a bit of experimentation I don't think the VMWare Tools are to blame. I did a clean install of Freya (0.3.2) and then immediately did sudo apt-get dist-upgrade (without installing the VMWare tools) and it hung on the next reboot. It's really odd - it seems to hang in a different place every time. FWIW, I'm running this in VMWare Fusion 7.1.3. – elfstein Feb 27 '16 at 2:05
  • Interesting. I got a freeze exactly when vmware tools failed booting (in that log when you are pressing delete button when logo shows up). Anyway, rolling back to the previous version has worked for me. – Anton Khaybulaev Feb 27 '16 at 23:46
1

So I fixed it by booting with previous version of kernel (hit escape two times, choose advanced options and pick any kernel you want) and then removing the latest kernel version (which wasn't good for the vmware tools) with Synaptic.

This article will tell you more: https://askubuntu.com/questions/106031/how-can-i-remove-new-kernel-versions-after-downgrading

1

Open a terminal (CTRL + ALT + T) and type sudo apt-get purge linux-image-3.19.0-49-generic and press enter.This will remove the new kernel.

WARNING : If you have removed the old kernel your VM may stop booting

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.