0

I have installed Chrome using this steps:

  • Add Key
  • Set repository
  • Install package using apt-get

But it didn’t start after I have clicked on new icon. After that I ran apt-upgrade. Then I decided to reboot system. If I remember right system froze and possibly KDE error appeared multiple times.

Now OS stops booting. It shows only on black screen with several messages that some services started and stopped.

So question is how to restore system to working state if it is possible.

UPD On the black screen there is message above others "could not write bytes: Broken pipe"

UPD 2. Have found solution!

0

Have found that some packages were not installed due to lack of space in temp folders. So here are steps that helped me:

  • I ran command inspired by this article link sudo apt-get -f install. I found that there was message "The following packages have been kept back".
  • Then I tried sudo apt-get install <list of packages kept back> from this post and found from multiple messages that cp: failed to extend ‘/tmp....
  • It appeared that overflow at /tmp was 100%. So the last few steps were to use sudo umount /tmp from this thread and to run sudo apt-get upgrade.
0

Are you by chance running elementary OS in a VM? Apparently there's a problem with the latest Ubuntu update (14.04.2, using kernel 3.19.0-51) that's causing virtual machines to fail on boot. The solution is to boot using an earlier version of the kernel. More info here:

http://ubuntuforums.org/showthread.php?t=2314723

  • Unfortunately its a host system, but thank you for suggestion. – romansh Feb 25 '16 at 19:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.