Hello so I have a AMD APU with a Radeon in it.

I installed the proprietary drivers via software sources, but I had some problems with them, so I switched back to the stock ones. A few days after that I switched back to prop drivers the same way, but this time the (updates) ones, since I need CS:GO fps ;)

That worked okay, but every startup it would take a few seconds longer than normal for the gui to show up. It did work well for some time like that.
I didn't investigate it further because way earlier I had completely broken my xorg and stuff with the AMD drivers and the script, so I was just happy it was working now.

A few minutes ago I did updates and upgrades and rebooted, after that I couldn't get into GUI again. Waiting obviously didn't work anymore, I did see that the apt-get update did update the fglx drivers.

So now I am stuck in console and can't even access the internet to install stuff etc. because I am using a wifi dongle. I did get it working via command line last time, but only with wep so I had to change the routers settings etc, this time I am asking you earlier so maybe I can avoid that. Any suggestions?

  • Don't use WEP on your WiFi router use Ethernet instead
    – Suici Doga
    Feb 25, 2016 at 2:11
  • I know I should do that. But I don't have long ethernet cables in my new home and the bigger issue, the router is in a different room where a flatmate lives in. She is already dealing with the router and a raspberry pi that is connected to it, so that is an issue.
    – bruno
    Feb 25, 2016 at 15:28
  • What happens when you run startx
    – Suici Doga
    Feb 26, 2016 at 2:32
  • it says Errors from xkbcomp are not fatal to the X server - xinit: connection to X server lost - waiting for X server to shut down... And I am back to Command line.
    – bruno
    Feb 28, 2016 at 17:32

1 Answer 1


https://askubuntu.com/questions/68306/how-do-i-remove-the-proprietary-ati-drivers Will this also work on elementary OS? I am afraid to try it, since last time I did stuff myself I must have made mistakes, so this time I am not touching it until I get confirmation. So I can access the internet now and did upgrades, but the issue still remains. If there is a way to fix the AMD drivers, I would be okay with that too, obviously. Again, I am using 64bit freya and didn't change anything but installed the AMD proprietary drivers via additional sources/gui.
I am the same dude btw, made a new account last time since I didn't think.

  • So I did follow the steps in the guide and deleted the fglrx* files, but the reinstall of xorg didn't work because of dependency issues. After that I was stuck in a login loop, but the answer to this question solved that issue: elementaryos.stackexchange.com/questions/2730/… My installation is still pretty broken I guess, but at least I can use the gui again.
    – sleepless
    Feb 29, 2016 at 2:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.