1

hi i'm having a wifi issue, i have win7 and ElementaryOs (ubuntu 14.04) on my toshiba satellite c55-c5206s with a broadcom BCM943142Y and the wifi randomly disconnects, it doesnt happen while im in windows. Linux is updated.

what i found, broadcom drivers are a little broken, and when wifi signal drop down from 55% the wireless constantly disconnects.

help please, i really want to start using linux full time

Hw Info

    > lspci -knn | grep Net  -A2  

    07:00.0 Network controller [0280]:
    > Broadcom Corporation BCM43142 802.11b/g/n [14e4:4365] (rev 01) 
    >   Subsystem: XAVi Technologies Corp. Device [1b9a:3002]   Kernel driver
    > in use: wl 

    > sudo lspci -knn  

    00:00.0 Host bridge [0600]: Intel Corporation
    > Haswell-ULT DRAM Controller [8086:0a04] (rev 0b)      Subsystem: Toshiba
    > America Info Systems Device [1179:f840]  00:02.0 VGA compatible
    > controller [0300]: Intel Corporation Haswell-ULT Integrated Graphics
    > Controller [8086:0a16] (rev 0b)   Subsystem: Toshiba America Info
    > Systems Device [1179:f840]    Kernel driver in use: i915  00:03.0 Audio
    > device [0403]: Intel Corporation Haswell-ULT HD Audio Controller
    > [8086:0a0c] (rev 0b)      Subsystem: Toshiba America Info Systems Device
    > [1179:f840]   Kernel driver in use: snd_hda_intel  00:14.0 USB
    > controller [0c03]: Intel Corporation 8 Series USB xHCI HC [8086:9c31]
    > (rev 04)      Subsystem: Toshiba America Info Systems Device [1179:f840] 
    >   Kernel driver in use: xhci_hcd  00:16.0 Communication controller
    > [0780]: Intel Corporation 8 Series HECI #0 [8086:9c3a] (rev 04) 
    >   Subsystem: Toshiba America Info Systems Device [1179:f840]      Kernel
    > driver in use: mei_me  00:1b.0 Audio device [0403]: Intel Corporation
    > 8 Series HD Audio Controller [8086:9c20] (rev 04)     Subsystem: Toshiba
    > America Info Systems Device [1179:f840]   Kernel driver in use:
    > snd_hda_intel  00:1c.0 PCI bridge [0604]: Intel Corporation 8 Series
    > PCI Express Root Port 1 [8086:9c10] (rev e4)      Kernel driver in use:
    > pcieport  00:1c.2 PCI bridge [0604]: Intel Corporation 8 Series PCI
    > Express Root Port 3 [8086:9c14] (rev e4)      Kernel driver in use:
    > pcieport  00:1c.3 PCI bridge [0604]: Intel Corporation 8 Series PCI
    > Express Root Port 4 [8086:9c16] (rev e4)      Kernel driver in use:
    > pcieport  00:1c.5 PCI bridge [0604]: Intel Corporation 8 Series PCI
    > Express Root Port 6 [8086:9c1a] (rev e4)      Kernel driver in use:
    > pcieport  00:1d.0 USB controller [0c03]: Intel Corporation 8 Series
    > USB EHCI #1 [8086:9c26] (rev 04)      Subsystem: Toshiba America Info
    > Systems Device [1179:f840]    Kernel driver in use: ehci-pci  00:1f.0
    > ISA bridge [0601]: Intel Corporation 8 Series LPC Controller
    > [8086:9c45] (rev 04)      Subsystem: Toshiba America Info Systems Device
    > [1179:f840]   Kernel driver in use: lpc_ich  00:1f.2 SATA controller
    > [0106]: Intel Corporation 8 Series SATA Controller 1 [AHCI mode]
    > [8086:9c03] (rev 04)      Subsystem: Toshiba America Info Systems Device
    > [1179:f840]   Kernel driver in use: ahci  00:1f.3 SMBus [0c05]: Intel
    > Corporation 8 Series SMBus Controller [8086:9c22] (rev 04) 
    >   Subsystem: Toshiba America Info Systems Device [1179:f840]  07:00.0
    > Network controller [0280]: Broadcom Corporation BCM43142 802.11b/g/n
    > [14e4:4365] (rev 01)      Subsystem: XAVi Technologies Corp. Device
    > [1b9a:3002]   Kernel driver in use: wl  08:00.0 Ethernet controller
    > [0200]: Realtek Semiconductor Co., Ltd. RTL8101/2/6E PCI Express
    > Fast/Gigabit Ethernet controller [10ec:8136] (rev 07)     Subsystem:
    > Toshiba America Info Systems Device [1179:f840]   Kernel driver in
    > use: r8169  09:00.0 Unassigned class [ff00]: Realtek Semiconductor
    > Co., Ltd. RTS5229 PCI Express Card Reader [10ec:5229] (rev 01) 
    >   Subsystem: Toshiba America Info Systems Device [1179:f840]      Kernel
    > driver in use: rtsx_pci
    > - Device: wlan0  [#$%#$%#$%$%] ------------------------------------------------    Type:              802.11 WiFi    Driver:            wl    State:             connected    Default:           yes    HW Address:        #$%#$%#$%#$%#$
    > 
    >   Capabilities: 
    >     Speed:           72 Mb/s 
    > 
    >   Wireless Properties 
    >     WEP Encryption:  yes 
    >     WPA Encryption:  yes 
    >     WPA2 Encryption: yes 
    > 
    >   Wireless Access Points (* = current AP) 
    >     *%#$%#$%#$%:   Infra, #$%#$%#$%$#%$#%, Freq 2462 MHz, Rate 54 Mb/s, Strength 57 WPA2 
    > 
    >   IPv4 Settings: 
    >     Address:         192.168.1.101 
    >     Prefix:          24 (255.255.255.0) 
    >     Gateway:         192.168.1.2 
    > 
    >     DNS:             192.168.1.2 
    > 
> - lshw
> *-network 
>                 description: Ethernet interface 
>                 product: RTL8101/2/6E PCI Express Fast/Gigabit Ethernet controller 
>                 vendor: Realtek Semiconductor Co., Ltd. 
>                 physical id: 0 
>                 bus info: pci@0000:08:00.0 
>                 logical name: eth0 
>                 version: 07 
>                 serial: #$%#$%#%$%#$
>                 size: 10Mbit/s 
>                 capacity: 100Mbit/s 
>                 width: 64 bits 
>                 clock: 33MHz 
>                 capabilities: pm msi pciexpress msix vpd bus_master cap_list rom ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd
> autonegotiation 
>                 configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=2.3LK-NAPI duplex=half
> firmware=rtl8106e-1_0.0.1 06/29/12 latency=0 link=no multicast=yes
> port=MII speed=10Mbit/s 
>                 resources: irq:46 ioport:3000(size=256) memory:a2404000-a2404fff memory:a2400000-a2403fff
> memory:8fb00000-8fb0ffff
> 
> 
> -
> 
-

> sudo iwconfig  eth0      no wireless extensions. 
> 
> wlan0     IEEE 802.11abg  ESSID:off/any   
>           Mode:Managed  Access Point: Not-Associated   Tx-Power=200 dBm    
>           Retry short limit:7   RTS thr:off   Fragment thr:off 
>           Encryption key:off 
>           Power Management:off 
>             bridge0   no wireless extensions. 
> 
> lo        no wireless extensions.
list of solutions i try:

apt-get update

apt-get upgrade

http://askubuntu.com/a/734963/509282

http://askubuntu.com/a/129634/509282

-

 sudo rfkill list all

0: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: no
1: brcmwl-0: Wireless LAN
    Soft blocked: no
    Hard blocked: no

update:

i tested the conection with the router right beside me and still i have an unstable conection.

people with the same problem:

https://elementaryos.stackexchange.com/questions/4451/having-some-wifi-erratic-behavior

WiFi connection dropping

https://elementaryos.stackexchange.com/questions/3895/lose-wifi-signal-about-4-5-times-a-day

  • This is a problem with broadcom.Change the laptop WiFi card to non broadcom – Suici Doga Feb 21 '16 at 6:48
  • Share the output of: sudo rfkill list all – bitseater Feb 21 '16 at 14:17
  • so you are telling that i need to change my wifi card to have a stable internet in linux, while in win7 i have a perfect and stable conection? – Rushiop Feb 22 '16 at 2:44
  • can anyone help me? – Rushiop Feb 22 '16 at 17:28
  • Are you tried sudo apt-get install bcmwl-kernel-source ?? – bitseater Feb 22 '16 at 22:58
1

I've got the same issue with my Dell Inspiron N5010 and the Broadcomm Wireless Adapter. There's a bug report where you can add some piece of information about the problem: https://bugs.launchpad.net/elementaryos/+bug/1080959.

Regards!

  • I also gave up. Linux mint worked like a charm ;-) – Damon Hill Oct 21 '16 at 7:51
0

after days searching for a solution, no solution found so far, so i give up.

  • Replace the WiFi card with Intel :) – Suici Doga Mar 5 '16 at 6:45
  • It happens with Intel chips too. – Garbee Dec 17 '16 at 16:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.