I cannot use ibus-unikey for typing Vietnamese.

In "keyboard layout" I can't found Vietnamese-Unikey (just "Vietnamese" only -> this is VNI keyboard)

With ibus-setup, I added English and VN-Unikey but I can't switch between those options. I checked keyboard shortcut and changed but it doesn't work at all.

2 Answers 2


Don't forget to restart ibus by command:

ibus restart

Find and add Vietnamese layout into ibus:



Final step - add ibus into the system tray:

Run this command in your terminal:

gsettings set org.gnome.desktop.input-sources sources "[('xkb', 'us'), ('ibus', 'Unikey')]"​

OR install dconf-editor then config it like picture:


Enjoy it!

  • I tried but it's not working (EOS 0.4.1 in Virtualbox)
    – pe-perry
    Commented May 20, 2017 at 13:30
  • doesn't work on 0.4.1
    – user2587
    Commented Aug 20, 2017 at 13:01

I know that this thread is very old now, but I just hope I can get an answer for those who may encounter it when using Elementary.

So to be blunt, we can use the command line to control Ibus instead of rely on the GUI thing. The commands are simple, in this case we will switch between English and Vietnamese, but other languages can apply without any problems.

Step 1: Get the English and Vietnamese engines

ibus list-engine

You should find the engines for English and Vietnamese as xkb:us::eng and Unikey, respectively

Step 2: Create the scripts for changing input methods I'm not a pro so I create simple scripts, you will need two here.

Create a bin directory if you haven't already, and cd into it:

mkdir -p newbin && cd newbin

Now the scripts, first is for US English input method:


ibus engine xkb:us::eng

Then for Vietnamese:


ibus engine Unikey

Save them as cim_en.sh and cim_vn.sh ("cim" stands for change input method)

Make them executable:

chmod 755 cim_en.sh cim_vn.sh

Finally, create keyboard shortcuts for them, first go to settings -> Keyboard -> Shortcuts -> Custom. Here, click the '+' icon at the bottom and create 2 keyboard shortcuts with the name of the scripts. Assign the key combinations that you want, then reboot if the scripts are not working already.

enter image description here

And that pretty much solved the problem for me.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.