3

My notebook is an ASUS X550DP that came with Windows 8.

I`m trying to make a dual-boot with Freya 0.3.2 64bits, but every time I try to install I get this error:

'grub-install /dev/sda' failed. This is a fatal error

I`m booting from a flash-drive in UEFI mode.

I left 60Gb for Freya, of which 20Gb is ext4 /, 36Gb is ext4 /home and 4Gb is a swap space.

What should I do?

3
  • The only suggestion I've received so far is to try the 32-bit version and report back.
    – Lewis Goddard
    Feb 16 '16 at 23:13
  • Connect your PC to the internet while installing.Also 0.3.2 fixes some UEFI bugs
    – Suici Doga
    Feb 17 '16 at 4:37
  • I ran into the exact same issue this week-end (64bits and separate partitions). First /dev/sda was taken by mu USB stick and not my SSD. After googling and finding multiple causes/fixes to this issue, I tried reconnecting my SSD on my port SATA-0, but it didn't help for me. You could try that. In the end I didn't create separate partition and installed Elementary with the default option, and it worked.
    – Slyvain
    Feb 18 '16 at 13:37
1

When you are trying to install elementary OS . The system gives you the option between installing automatically with Windows and advanced options where you can do the partitioning.

I suppose that you chose the second option, there you can find at the bottom and before you start installation, an option asking you where you want to install the boot loader, but there you have to choose the disk and partition where you want to install it, try changing /dev/sda to /dev/sda1 (obviously only if /dev/sda1 is one of the Linux partition, not Windows one)

As an example, years ago i was installing Kubuntu and my computer never boot, i put my booteable sd-flash for reinstall but i didn't change the priority boot, and computer finally start, then i realize that i had installed the "start sector" in the sd-flash that was at the instalation " sda ".

1
  • I think you mean boot sector or boot loader instead of startup sector
    – Suici Doga
    Apr 23 '16 at 11:43
1

I had that problem with Freya 0.3.2 on my Asus X552V. So far the only solution that worked for me is instaling 0.3.1 and then just upgrade it. After that, everything works fine.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.