I tried to install the proprietary fglrx AMD graphics driver on my computer which is running Freya, however it didn't work. Seems my graphics card is just too old and is no longer supported. (That's the last AMD card i'm going to be buying.)

Long story short I purged the installation of fglrx* but now it just boots to a blanks screen. I can still access the command line and strangely enough within command line it does seem to be using the correct driver (or at least recognizing my monitor's native resolution)

Nothing I've done so far seems to be working, and following any of the guides I've found online have been fruitless. (They're all written for Ubuntu which doesn't error out when trying to reinstall xserver-xorg with an error about gnome-control-center)

Any help would be greatly appreciated. At this point I'm just trying to revert to the graphics drivers it was using after installing from the CD-ROM.

And before anyone says it, no reinstalling is not an option.

3 Answers 3


if you can access to the command line just put this commands:

sudo apt-get remove --purge xorg-driver-fglrx fglrx*
sudo apt-get install --reinstall libgl1-mesa-glx libgl1-mesa-dri xserver-xorg-core
sudo reconfigure xserver-xorg

If you need more info you can check the ubuntu wiki post about graphic drivers here.

  • Thanks, this solved my problem. Sorry it took so long to respond.
    – Vanessa
    Commented Nov 17, 2017 at 4:12

unfortunately Nov '17 was 3 years ago and these instructions may not work because the packages that are referred to no longer exist in the usual package repositories.


Try chroot from LiveCD

sudo -i
mount /dev/sdaX /mnt
mount --bind /dev /mnt/dev
mount --bind /sys /mnt/sys
mount -t proc /proc /mnt/proc
chroot /mnt
nano /etc/resolv.conf

Add these lines to file, save and close it

nameserver nameserver

Amd provides an unistaller under /usr/share/ati (realy i don't remember the exact path)

/path-to-uninstaller-executable #if you have installed from AMD website
apt-get purge fglrx fglrx-core #if you used apt
apt-get update
apt-get install xserver-xorg-lts-utopic

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.