I recently tried to dual boot Elementary OS with Windows 7. I can see WiFi networks but when I try and connect to them, it asks for the password then tries to connect. After a while it stops and asks me the password again. I'm using a TP-LINK TL-WN881ND Wireless Adapter. Thanks for all your help in advance. Tell me if you need any other information.

Update: What terminal says after sudo lshw -C network

 elementary@elementary:~$ sudo lshw -C network
   description: Wireless interface
   product: AR9287 Wireless Network Adapter (PCI-Express)
   vendor: Qualcomm Atheros
   physical id: 0
   bus info: pci@0000:03:00.0
   logical name: wlan0
   version: 01
   serial: e8:94:f6:fb:2b:ff
   width: 64 bits
   clock: 33MHz
   capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
   configuration: broadcast=yes driver=ath9k driverversion=3.19.0-39-generic firmware=N/A latency=0 link=no multicast=yes wireless=IEEE 802.11bgn
   resources: irq:32 memory:fe800000-fe80ffff
   description: Ethernet interface
   product: RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
   vendor: Realtek Semiconductor Co., Ltd.
   physical id: 0
   bus info: pci@0000:04:00.0
   logical name: eth0
   version: 06
   serial: 74:d4:35:99:77:fd
   size: 10Mbit/s
   capacity: 1Gbit/s
   width: 64 bits
   clock: 33MHz
   capabilities: pm msi pciexpress msix vpd bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd 1000bt 1000bt-fd autonegotiation
   configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=2.3LK-NAPI duplex=half firmware=rtl8168e-3_0.0.4 03/27/12 latency=0 link=no multicast=yes port=MII speed=10Mbit/s
   resources: irq:29 ioport:d000(size=256) memory:fe700000-fe700fff memory:d0000000-d0003fff
  • What if you type the key phrase in a text editor and then select & paste it in the wireless password dialogue box?
    – user4108
    Commented Feb 14, 2016 at 18:10
  • Tried that, it still keeps on asking me for the password.
    – W.Lynxe
    Commented Feb 14, 2016 at 18:24
  • That wireless adapter use the Ath9k driver, supported in elementary-os and Ubuntu derivates by default. Type the next command and copy&paste the output: sudo lshw -C network
    – bitseater
    Commented Feb 15, 2016 at 20:36
  • 1
    Please edit to add iwlist scan | egrep -i 'ssid|cipher' and post what one you are trying to connect to
    – Jeremy31
    Commented Feb 20, 2016 at 21:48

1 Answer 1


Try System Settings/Network/Wireless/click on your wireless network. go to Settings/wi-fi security/ and double check that your password has been entered and spelled correctly,perhaps re-entering it and manually saving.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.