1

Like I said, I don't know how to get the stock network manager to connect to a network. I am on a late 2010 MacBook Air, so I don't have an ethernet port. I need wifi to connect to the internet. Everything else is running fine and dandy.

I'd usually assign this to some problems with the drivers or the firmware. This being a MacBook makes it even more likely. However, the weird part is that I CAN connect to wifi with no problems at all if I use the terminal. Here are the commands I use:

    sudo service network-manager stop
    sudo iwconfig wlan0 essid <Enter SSID here>
    sudo dhclient -v wlan0

This makes it all work perfectly. But the thing is, it's a pain in the ass to connect to any network with a password, and it also doesn't support automatic reconnecting or anything like that. I don't want to have to do this every time.

Here are some other things I've tried:

    sudo apt-get remove --purge network-manager
    sudo apt-get autoremove
    sudo apt-get install network-manager

This didn't help. It wasn't just a bad install.

I tried instaling WICD instead and seeing if that would work, but there were some things wrong with it. First, I couldn't get it into wingpanel. Second, it's as ugly as all hell. Third, it still wouldn't connect to a network. Seriously, it did the same thing the stock network manager did. Got stuck on "Obtaining IP Address".

I don't know what to do, guys. Can anyone help? Much appreciated.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.