2

My Lenovo G40 has a BR layout keyboard that works fine until I bough a US layout mechanical keyboard, after that I cannot set the us layout as default in any way. It aways change to BR, after and after. A simple alt+tab is enough to reconfigure my keyboard settings.

I already tried to run:

  • setxkbmap -rules evdev -model evdev -layout us -variant intl -option caps:ctrl_modifier
  • gsettings set org.gnome.desktop.input-sources current 0
  • sudo dpkg-reconfigure keyboard-configuration

Every command works fine until I change the current windows, that imediatly changes to br layout again.

I want my configurations in that way:

squiter@stark:~$ setxkbmap -print -verbose 10
Setting verbose level to 10
locale is C
Trying to load rules file ./rules/evdev...
Trying to load rules file /usr/share/X11/xkb/rules/evdev...
Success.
Applied rules from evdev:
rules:      evdev
model:      evdev
layout:     us
variant:    intl
options:    caps:ctrl_modifier
Trying to build keymap using the following components:
keycodes:   evdev+aliases(qwerty)
types:      complete
compat:     complete
symbols:    pc+us(intl)+inet(evdev)+capslock(ctrl_modifier)
geometry:   pc(pc104)
xkb_keymap {
    xkb_keycodes  { include "evdev+aliases(qwerty)" };
    xkb_types     { include "complete"  };
    xkb_compat    { include "complete"  };
    xkb_symbols   { include "pc+us(intl)+inet(evdev)+capslock(ctrl_modifier)"   };
    xkb_geometry  { include "pc(pc104)" };
}

But every time I change current app window it transform in that:

squiter@stark:~$ setxkbmap -print -verbose 10
Setting verbose level to 10
locale is C
Trying to load rules file ./rules/evdev...
Trying to load rules file /usr/share/X11/xkb/rules/evdev...
Success.
Applied rules from evdev:
rules:      evdev
model:      evdev
layout:     br,us
variant:    ,intl
options:    caps:ctrl_modifier
Trying to build keymap using the following components:
keycodes:   evdev+aliases(qwerty)
types:      complete
compat:     complete
symbols:    pc+br+us(intl):2+inet(evdev)+capslock(ctrl_modifier)
geometry:   pc(pc104)
xkb_keymap {
    xkb_keycodes  { include "evdev+aliases(qwerty)" };
    xkb_types     { include "complete"  };
    xkb_compat    { include "complete"  };
    xkb_symbols   { include "pc+br+us(intl):2+inet(evdev)+capslock(ctrl_modifier)"  };
    xkb_geometry  { include "pc(pc104)" };
};

I took some scrrenshots of my configurations: https://www.dropbox.com/sh/14df99r65213vot/AAB5IhOqxOY7d8_RPoTQo8fga?dl=0

1

I was just looking at another answer (https://elementaryos.stackexchange.com/a/9277/7446 ) to a related question (about why shift-alt-tab behaviour was strange), and I think it might explain your problem too. In Elementary, go to settings -> keyboard -> layout, and you might find that shift-alt-tab is mapped to switch keyboard layouts. I disabled that mapping, and now alt-tab and shift-alt-tab work fine for me; I'm guessing this will also stop your keyboard layout from changing!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.