I installed a OS alongside OS X on my old Macbook with rEFIt.

When I boot into Elementary it fails to load the Desktop environment and shows me the terminal.

Do you guys have any ideas to how I can fix this?

  • Why are you using Luna?
    – Suici Doga
    Feb 12 '16 at 9:52
  • My computer crashed and I happened to have an old live CD. Do you think that would fix it? Feb 12 '16 at 10:58
  • Using Freya should fix it. You should have done that before posting on this site. Also I recommend using USBs instead of CDs
    – Suici Doga
    Feb 12 '16 at 11:11
  • What is did it have when it crashed. What do you mean by crashed?
    – Suici Doga
    Feb 12 '16 at 13:30
  • During boot the screen would flicker as if the desktop was trying to launch and then do some cool glitch art thing and go to the terminal. Feb 13 '16 at 17:57

Updating to Freya did solve the problem. I ran sudo apt-get dist-upgrade and everything worked perfectly.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.