4

Consider this question on how to change the login picture.

I cannot in fact follow none of the answers posted there.

But even before re-asking a question like "how to change the login image" I would like to know:

Should the login use the desktop picture? Should it change when the desktop one is changed and so be the same? Because in my case it is NOT.

I use to change the desktop wallpaper by going to Settings - Desktop - Wallpaper or just right clicking an image 'Set as desktop background' in Files.

My login screen is (was) this one no matter what desktop wallpaper I selected:

enter image description here

That is, until I followed this answer and now the login image is missing: black.

The folder /usr/share/backgrounds looks like so:

enter image description here

Notice the added images at the end and the symlink that was created following the linked answer.

But they are not accessible from Settings:

enter image description here


I found a fix to the lost login image:

  • Selected one of the default wallpapers that are visible from Settings - Desktop - Wallpaper

  • Then changed desktop wallpaper again: in this way the login has an image: the one before the last change of the desktop image.


In fact it's a bug. Also, has a workaround: here, also here.

closed as off-topic by user170, user3, Daniel Foré, Huey, Lewis Goddard Jul 13 '15 at 17:35

  • This question does not appear to be about elementary OS, within the scope defined in the help center.
If this question can be reworded to fit the rules in the help center, please edit the question.

3

Related answer: here.

The answer to my question is YES: the login image should also change just by selecting one of the images in /usr/share/backgrounds from System Settings -Desktop - Wallpaper.

In fact there is a bug where the login picture cannot be changed:

https://bugs.launchpad.net/elementaryos/+bug/1391716

also:

https://bugs.launchpad.net/pantheon-greeter/+bug/1324373

In this case the new images copied into usr/share/backgroounds may not even be seen from System Settings -Desktop - Wallpaper.

To fix this:

  • Open Files as administrator

  • Select the image file in /usr/share/backgrounds and open its Properties (if you want a new one copy it there first)

  • Change permissions to 644

enter image description here

  • Use System Settings -Desktop - Wallpaper as normal