2

Recently I dual booted my laptop HP Pavilion Notebook ab219tx with Windows 10 and elementary OS 0.3.2. At first it connected to my WiFi but poor signal and internet speed is also very slow even through I am near to the router and after some time it just continuously connecting and disconnecting but when I tried with my mobile hotspot it just worked fine.So

  • To know your chipset wifi card, try in a terminal: sudo lshw -C network. Copy & paste the results. – bitseater Feb 12 '16 at 1:15
  • /0/100/1c.2/0 wlano network RTL8723BE PCIe wireless network adapter @bitseater – The Learner Feb 13 '16 at 14:21
1

HP has recently been using only one antenna on a wireless card with two connectors. Larry Finger with some help from Realtek came up with the solution

sudo apt-get install git linux-headers-generic build essential
git clone git://github.com/lwfinger/rtlwifi_new.git
cd rtlwifi_new
git checkout rock.new_btcoex
make
sudo make install

Reboot. Then try

sudo modprobe -rv rtl8723be
sudo modprobe -v rtl8723be ant_sel=1

Check to see if wireless access points are detected

iwlist scan | egrep -i 'ssid|signal'

If nothing is detected or very weak signal, then try

sudo modprobe -rv rtl8723be
sudo modprobe -v rtl8723be ant_sel=2

Then test to check wifi signal strength

iwlist scan | egrep -i 'ssid|signal'

One or the other ant_sel parameter settings should result in better wifi signal strength and you can set it with

echo "options rtl8723be ant_sel=X" | sudo tee /etc/modprobe.d/rtl-ant-sel.conf

Where X is either 1 or 2 based on what gave you better results

0

This wifi network card has some issues with kernels in Trusty Ubuntu and derivates. You can try from terminal:

echo "options rtl8723be fwlps=N ips=N" | sudo tee /etc/modprobe.d/rtl8723be.conf

This trick makes possible a new management of the card and its prevent the card to go to suspend mode.

You must restart your computer after use this command, or reload the driver with these commands:

sudo modprobe -r rtl8723be
sudo modprobe rtl8723be

More info about this known bug for Ubuntu 14.04 and derivates at:

Ubuntu bugs at Launchpad

If this option doesn't work, you can install a new Realtek driver from the rtwifi_new repo:

sudo apt-get install linux-headers-generic build-essential git
git clone http://github.com/lwfinger/rtlwifi_new
cd rtlwifi_new
make
sudo make install 

And then reboot or reload the driver how it explain before.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.