3

I recently bought an Asus X554LA laptop, on which Freya works flawlessly.
Unfortunately the internal wifi board (Mediatek MT7630E) is not supported on Linux, there are some unofficial drivers but I failed to install them.

If I run "sudo lshw -C network" the output I get is:
*-network
description: Ethernet interface product: RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller vendor: Realtek Semiconductor Co., Ltd. physical id: 0 bus info: pci@0000:02:00.0 logical name: eth0 version: 10 serial: 1c:b7:2c:96:2f:65 size: 100Mbit/s capacity: 1Gbit/s width: 64 bits clock: 33MHz capabilities: pm msi pciexpress msix vpd bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd 1000bt 1000bt-fd autonegotiation configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=2.3LK-NAPI duplex=full firmware=rtl8168g-3_0.0.1 04/23/13 ip=192.168.1.93 latency=0 link=yes multicast=yes port=MII speed=100Mbit/s resources: irq:47 ioport:e000(size=256) memory:f7104000-f7104fff memory:f7100000-f7103fff *-network UNCLAIMED description: Network controller product: MT7630e 802.11bgn Wireless Network Adapter vendor: MEDIATEK Corp. physical id: 0 bus info: pci@0000:03:00.0 version: 00 width: 32 bits clock: 33MHz capabilities: pm msi pciexpress bus_master cap_list configuration: latency=0 resources: memory:f7000000-f70fffff

In order to make the chipset work I tried to update the kernel (I am currently running 4.4.1-040401-generic). I also tried to install this unofficial driver link (and other versions of it as well) but when I launch "./install" I get an error mentioning -fstack-protector-strong not supported by compiler (I won't post the whole output because it cointains a lot of backticks and mess up the markdown layout).

As a workaround I tried to use a wifi dongle (Edimax EW-7811Un) which worked fine once I installed the drivers, but its antenna has a very short range, so overall it's not a viable solution.

Do anybody know a solution to install the driver?

  • That wifi card is certified by Ubuntu in some laptops: ubuntu.com/certification/catalog/component/pci/14c3%3A7630 . Can you copy and paste the results of the command "sudo lshw - C network"? – bitseater Feb 9 '16 at 15:55
  • I couldn't really figure how to post code-formatted test, so I took a screenshot instead link. It seems like the system does recognize the hardware, but doesn't know how to get it to work properly. – drgeppo Feb 9 '16 at 17:24
  • You can edit your question and add code with the preformatted text tag, marked with {}. About your issue, I can see a "network UNCLAIMED" line. This means that your system doesn't load any driver for this card. Try in terminal with the command: modprobe rt2x00pci . Comment the output. – bitseater Feb 9 '16 at 17:32
  • Thank you. Anyway if I run the modprobe command nothing happens, and the output of lshw -C network is the same – drgeppo Feb 9 '16 at 17:42
  • There are some modificated drivers. I suposse you're running kernel 3.19, isn't it? If you don't know, try in terminal : uname -a – bitseater Feb 9 '16 at 17:49
0

Mediatek MT7630E driver with kernel 4.4 support

In order to compile a new driver, you must open a terminal and execute:

sudo apt-get install --reinstall git linux-headers-$(uname -r) build-essential dkms

In elementary OS Freya you must install too the new gcc compiler. Open a terminal and write:

sudo add-apt-repository ppa:ubuntu-toolchain-r/test
sudo apt-get update 
sudo apt-get install g++-5

Now you can try to download the driver from the zip source at:

neurobin github.com

and unzipped it, or you just clone it with git in a terminal:

git clone https://github.com/neurobin/MT7630E.git

After download, you must enter in the new created folder. Open the file README.md and follow instructions to install the new driver.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.