0

Big linux noob ahead, so please be kind if I don't exactly understand everything I'm talking about here.

I installed Ubuntu on my father's old macbook 4.1 a few days ago, and it worked just fine. Today we tried to install Elementary OS (multiple times) but it always got stuck on a black screen with a blinking white line - holding shift during boot did nothing.

After searching around a bit, I decided to try and reinstall grub2 with the tool "boot-repair". Didn't fix the issue, so I tried to reboot to reinstall Elementary without installing updates. I noticed that there now was a third option in the apple boot-menu: "EFI boot" (aside from "Windows", the one that would normally start ubuntu, and then my usb installation media). I thought "what the hell" and tried the option.

Here I am greeted by a quick screen that says

Failed to open \EFI\BOOT\grubx64.efi - Not Found
Failed to load image \EFI\BOOT\grubx64.efi: Not Found
Failed to open \EFI\BOOT\MokManager.efi - Not Found
Failed to load image \EFI\BOOT\MokManager.efi: Not Found

From here I can simply choose "elementary os" and the computer boots as it is supposed to.

I also tried some other things in the midst of things, including following this guide for Debian, and applying it to ubuntu.

Sorry if this has already been answered

1

I managed to fix the issue by reinstalling (though I don't think it was necessary) following these instructions, though I think it was mainly the last part that helped.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.