4

I can't open the Software Center - it simply doesn't launch. No errors or anything pop up when I try to run it from Slingshot.

I have an error in the topbar that looks like the red stop sign in this. I think it may be the cause of the issue:

enter image description here

I've had this error for over a month, but haven't been able to get it to disappear yet. I've just run the following commands with no errors, and they all completed successfully:

sudo apt-get update
sudo apt-get upgrade
sudo apt-get dist-upgrade

Yet after running those and rebooting, I still have the same error in the topbar. When I first boot it doesn't show, but after about 30 seconds to around 1 minute it does.

I can also run also successfully run all the items in the error dropdown, like Show updates, Install all updates, Check for updates and Start package manager successfully.

If I run software-center from the command-line, I do get errors and useful output:

de@dust:~$ software-center

** (software-center:4322): WARNING **: Couldn't connect to accessibility bus: Failed to connect to socket /tmp/dbus-IDTKNudikr: Connection refused
ERROR:root:DebFileApplication import
Traceback (most recent call last):
  File "/usr/share/software-center/softwarecenter/db/__init__.py", line 4, in <module>
from debfile import DebFileApplication, DebFileOpenError
  File "/usr/share/software-center/softwarecenter/db/debfile.py", line 25, in <module>
from softwarecenter.db.application import Application, AppDetails
  File "/usr/share/software-center/softwarecenter/db/application.py", line 28, in <module>
import softwarecenter.distro
  File "/usr/share/software-center/softwarecenter/distro/__init__.py", line 208, in <module>
distro_instance = _get_distro()
  File "/usr/share/software-center/softwarecenter/distro/__init__.py", line 183, in _get_distro
module = __import__(distro_module_name, globals(), locals(), [], -1)
ImportError: No module named elementary os
Traceback (most recent call last):
  File "/usr/bin/software-center", line 128, in <module>
from softwarecenter.ui.gtk3.app import SoftwareCenterAppGtk3
  File "/usr/share/software-center/softwarecenter/ui/gtk3/app.py", line 54, in <module>
from softwarecenter.db.application import Application
  File "/usr/share/software-center/softwarecenter/db/application.py", line 28, in <module>
import softwarecenter.distro
  File "/usr/share/software-center/softwarecenter/distro/__init__.py", line 208, in <module>
distro_instance = _get_distro()
  File "/usr/share/software-center/softwarecenter/distro/__init__.py", line 183, in _get_distro
module = __import__(distro_module_name, globals(), locals(), [], -1)
ImportError: No module named elementary os

How can I solve this? I need Software Centre running so that I can install .deb files again.

Thanks!

EDIT:

As requested by @sale, here's the useful output of some commands:

sudo apt-get update

Ign http://au.archive.ubuntu.com trusty InRelease
Get:1 http://au.archive.ubuntu.com trusty-updates InRelease [64.4 kB]          
Ign http://dl.google.com stable InRelease                                      
Hit http://repo.steampowered.com precise InRelease                             
Ign http://archive.canonical.com trusty InRelease                              
Hit http://ppa.launchpad.net trusty InRelease                                  
Get:2 http://security.ubuntu.com trusty-security InRelease [64.4 kB]           
Get:3 http://au.archive.ubuntu.com trusty-backports InRelease [64.5 kB]        
Hit http://repository.spotify.com stable InRelease                             
Get:4 http://au.archive.ubuntu.com trusty-proposed InRelease [212 kB]          
Hit http://repo.steampowered.com precise/steam Sources                         
Hit http://archive.canonical.com trusty Release.gpg                            
Ign http://dl.google.com stable InRelease                                      
Ign http://ppa.launchpad.net trusty InRelease                                  
Hit http://au.archive.ubuntu.com trusty Release.gpg                            
Hit http://repository.spotify.com stable/non-free amd64 Packages               
Hit http://dl.google.com stable Release.gpg                                    
Get:5 http://au.archive.ubuntu.com trusty-updates/main Sources [250 kB]        
Hit http://repo.steampowered.com precise/steam amd64 Packages                  
Hit http://archive.canonical.com trusty Release                                
Ign http://ppa.launchpad.net trusty InRelease                                  
Hit http://repository.spotify.com stable/non-free i386 Packages                
Hit http://archive.canonical.com trusty/partner Sources                        
Hit http://repo.steampowered.com precise/steam i386 Packages                   
Get:6 http://security.ubuntu.com trusty-security/multiverse Sources [2,350 B]  
Ign http://ppa.launchpad.net trusty InRelease                                  
Hit http://dl.google.com stable Release.gpg                                    
Get:7 http://au.archive.ubuntu.com trusty-updates/restricted Sources [5,359 B] 
Hit http://archive.canonical.com trusty/partner amd64 Packages                 
Hit http://dl.google.com stable Release                                        
Get:8 http://security.ubuntu.com trusty-security/multiverse amd64 Packages [4,797 B]
Hit http://ppa.launchpad.net trusty InRelease                                  
Get:9 http://au.archive.ubuntu.com trusty-updates/universe amd64 Packages [336 kB]
Hit http://archive.canonical.com trusty/partner i386 Packages                  
Get:10 http://security.ubuntu.com trusty-security/multiverse i386 Packages [4,976 B]
Ign http://ppa.launchpad.net trusty InRelease                                  
Hit http://archive.canonical.com trusty/partner Translation-en                 
Hit http://dl.google.com stable Release                                        
Get:11 http://security.ubuntu.com trusty-security/multiverse Translation-en [2,437 B]
Hit http://ppa.launchpad.net trusty InRelease                                  
Hit http://dl.google.com stable/main amd64 Packages                            
Get:12 http://au.archive.ubuntu.com trusty-updates/multiverse amd64 Packages [13.0 kB]
Get:13 http://au.archive.ubuntu.com trusty-updates/main amd64 Packages [696 kB]
Ign http://repository.spotify.com stable/non-free Translation-en_AU            
Hit http://ppa.launchpad.net trusty InRelease                                  
Ign http://repository.spotify.com stable/non-free Translation-en               
Hit http://ppa.launchpad.net trusty InRelease                                  
Hit http://dl.google.com stable/main i386 Packages                             
Ign http://ppa.launchpad.net trusty InRelease                                  
Get:14 http://au.archive.ubuntu.com trusty-updates/restricted amd64 Packages [15.9 kB]
Get:15 http://au.archive.ubuntu.com trusty-updates/universe i386 Packages [337 kB]
Hit http://ppa.launchpad.net trusty/main Sources                               
Get:16 http://au.archive.ubuntu.com trusty-updates/multiverse i386 Packages [13.2 kB]
Get:17 http://au.archive.ubuntu.com trusty-updates/main i386 Packages [671 kB] 
Hit http://dl.google.com stable/main amd64 Packages                            
Hit http://ppa.launchpad.net trusty/main amd64 Packages                        
Hit http://dl.google.com stable/main i386 Packages                             
Get:18 http://au.archive.ubuntu.com trusty-updates/restricted i386 Packages [15.6 kB]
Ign http://repo.steampowered.com precise/steam Translation-en_AU               
Get:19 http://au.archive.ubuntu.com trusty-updates/main Translation-en [352 kB]
Hit http://ppa.launchpad.net trusty/main i386 Packages                         
Ign http://repo.steampowered.com precise/steam Translation-en                  
Hit http://ppa.launchpad.net trusty/main Translation-en                        
Get:20 http://au.archive.ubuntu.com trusty-updates/multiverse Translation-en [6,832 B]
Get:21 http://au.archive.ubuntu.com trusty-updates/restricted Translation-en [3,699 B]
Get:22 http://au.archive.ubuntu.com trusty-updates/universe Translation-en [179 kB]
Hit http://ppa.launchpad.net trusty Release.gpg                                
Get:23 http://au.archive.ubuntu.com trusty-backports/main Sources [8,236 B]    
Hit http://ppa.launchpad.net trusty Release.gpg                                
Get:24 http://au.archive.ubuntu.com trusty-backports/restricted Sources [28 B] 
Get:25 http://au.archive.ubuntu.com trusty-backports/universe Sources [33.2 kB]
Hit http://ppa.launchpad.net trusty Release.gpg                                
Get:26 http://au.archive.ubuntu.com trusty-backports/multiverse Sources [1,898 B]
Get:27 http://au.archive.ubuntu.com trusty-backports/universe amd64 Packages [39.8 kB]
Get:28 http://au.archive.ubuntu.com trusty-backports/multiverse amd64 Packages [1,571 B]
Hit http://ppa.launchpad.net trusty/main amd64 Packages                        
Get:29 http://au.archive.ubuntu.com trusty-backports/main amd64 Packages [9,391 B]
Get:30 http://au.archive.ubuntu.com trusty-backports/restricted amd64 Packages [28 B]
Get:31 http://au.archive.ubuntu.com trusty-backports/universe i386 Packages [39.8 kB]
Get:32 http://au.archive.ubuntu.com trusty-backports/multiverse i386 Packages [1,552 B]
Get:33 http://au.archive.ubuntu.com trusty-backports/main i386 Packages [9,442 B]
Get:34 http://au.archive.ubuntu.com trusty-backports/restricted i386 Packages [28 B]
Hit http://au.archive.ubuntu.com trusty-backports/main Translation-en          
Hit http://au.archive.ubuntu.com trusty-backports/multiverse Translation-en    
Hit http://ppa.launchpad.net trusty/main i386 Packages                         
Hit http://au.archive.ubuntu.com trusty-backports/restricted Translation-en    
Hit http://au.archive.ubuntu.com trusty-backports/universe Translation-en      
Get:35 http://au.archive.ubuntu.com trusty-proposed/universe amd64 Packages [23.6 kB]
Hit http://ppa.launchpad.net trusty/main Translation-en                        
Get:36 http://au.archive.ubuntu.com trusty-proposed/multiverse amd64 Packages [28 B]
Get:37 http://au.archive.ubuntu.com trusty-proposed/main amd64 Packages [148 kB]
Hit http://ppa.launchpad.net trusty Release.gpg                                
Get:38 http://au.archive.ubuntu.com trusty-proposed/restricted amd64 Packages [3,655 B]
Get:39 http://au.archive.ubuntu.com trusty-proposed/universe i386 Packages [23.4 kB]
Hit http://ppa.launchpad.net trusty/main amd64 Packages                        
Get:40 http://au.archive.ubuntu.com trusty-proposed/multiverse i386 Packages [733 B]
Get:41 http://au.archive.ubuntu.com trusty-proposed/main i386 Packages [144 kB]
Hit http://ppa.launchpad.net trusty/main i386 Packages                         
Get:42 http://au.archive.ubuntu.com trusty-proposed/restricted i386 Packages [3,661 B]
Hit http://au.archive.ubuntu.com trusty-proposed/main Translation-en_AU        
Hit http://au.archive.ubuntu.com trusty-proposed/main Translation-en           
Hit http://au.archive.ubuntu.com trusty-proposed/multiverse Translation-en_AU  
Hit http://ppa.launchpad.net trusty/main Translation-en                        
Hit http://au.archive.ubuntu.com trusty-proposed/multiverse Translation-en     
Hit http://au.archive.ubuntu.com trusty-proposed/restricted Translation-en_AU  
Hit http://au.archive.ubuntu.com trusty-proposed/restricted Translation-en     
Hit http://au.archive.ubuntu.com trusty-proposed/universe Translation-en       
Hit http://ppa.launchpad.net trusty/main Sources                               
Hit http://au.archive.ubuntu.com trusty Release                                
Hit http://au.archive.ubuntu.com trusty/main Sources                           
Hit http://au.archive.ubuntu.com trusty/restricted Sources                     
Hit http://au.archive.ubuntu.com trusty/universe Sources                       
Hit http://ppa.launchpad.net trusty/main amd64 Packages                        
Hit http://au.archive.ubuntu.com trusty/multiverse Sources                     
Hit http://au.archive.ubuntu.com trusty/main amd64 Packages                    
Hit http://au.archive.ubuntu.com trusty/restricted amd64 Packages              
Hit http://au.archive.ubuntu.com trusty/universe amd64 Packages                
Hit http://ppa.launchpad.net trusty/main i386 Packages                         
Hit http://au.archive.ubuntu.com trusty/multiverse amd64 Packages              
Hit http://au.archive.ubuntu.com trusty/main i386 Packages                     
Hit http://au.archive.ubuntu.com trusty/restricted i386 Packages               
Hit http://au.archive.ubuntu.com trusty/universe i386 Packages     
Hit http://au.archive.ubuntu.com trusty/multiverse i386 Packages   
Hit http://ppa.launchpad.net trusty/main Translation-en            
Hit http://au.archive.ubuntu.com trusty/main Translation-en_AU                 
Hit http://au.archive.ubuntu.com trusty/main Translation-en                    
Hit http://au.archive.ubuntu.com trusty/multiverse Translation-en_AU           
Hit http://au.archive.ubuntu.com trusty/multiverse Translation-en              
Hit http://ppa.launchpad.net trusty/main amd64 Packages            
Hit http://au.archive.ubuntu.com trusty/restricted Translation-en_AU
Hit http://au.archive.ubuntu.com trusty/restricted Translation-en  
Hit http://au.archive.ubuntu.com trusty/universe Translation-en_AU             
Hit http://au.archive.ubuntu.com trusty/universe Translation-en                
Hit http://ppa.launchpad.net trusty/main i386 Packages                         
Ign http://dl.google.com stable/main Translation-en_AU                         
Hit http://ppa.launchpad.net trusty/main Translation-en                        
Ign http://dl.google.com stable/main Translation-en                            
Hit http://ppa.launchpad.net trusty Release.gpg                                
Ign http://dl.google.com stable/main Translation-en_AU                         
Hit http://ppa.launchpad.net trusty Release                                    
Hit http://ppa.launchpad.net trusty Release                                    
Ign http://dl.google.com stable/main Translation-en                            
Hit http://ppa.launchpad.net trusty Release                                    
Hit http://ppa.launchpad.net trusty Release                                    
Hit http://ppa.launchpad.net trusty Release                                    
Hit http://ppa.launchpad.net trusty/main amd64 Packages                        
Hit http://ppa.launchpad.net trusty/main i386 Packages                         
Hit http://ppa.launchpad.net trusty/main Translation-en                        
Hit http://ppa.launchpad.net trusty/main amd64 Packages                        
Hit http://ppa.launchpad.net trusty/main i386 Packages                         
Hit http://ppa.launchpad.net trusty/main amd64 Packages                        
Hit http://ppa.launchpad.net trusty/main i386 Packages                         
Hit http://ppa.launchpad.net trusty/main Translation-en                        
Hit http://ppa.launchpad.net trusty/main amd64 Packages                        
Hit http://ppa.launchpad.net trusty/main i386 Packages                         
Hit http://ppa.launchpad.net trusty/main Translation-en                        
Hit http://ppa.launchpad.net trusty/main amd64 Packages                        
Hit http://ppa.launchpad.net trusty/main i386 Packages                         
Hit http://ppa.launchpad.net trusty/main Translation-en                        
Ign http://ppa.launchpad.net trusty/main Translation-en_AU                     
Ign http://ppa.launchpad.net trusty/main Translation-en                        
Fetched 3,805 kB in 25s (147 kB/s)                                             
Reading package lists... Done

sudo apt-get upgrade

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Done
The following packages were automatically installed and are no longer required:
  filezilla-common libtinyxml2.6.2
Use 'apt-get autoremove' to remove them.
The following packages have been kept back:
  ffmpeg
The following packages will be upgraded:
  firefox firefox-locale-en
2 to upgrade, 0 to newly install, 0 to remove and 1 not to upgrade.
Need to get 42.7 MB of archives.
After this operation, 20.5 kB disk space will be freed.
Do you want to continue? [Y/n] Y
Get:1 http://au.archive.ubuntu.com/ubuntu/ trusty-updates/main firefox amd64 44.0.1+build2-0ubuntu0.14.04.1 [42.0 MB]
Get:2 http://au.archive.ubuntu.com/ubuntu/ trusty-updates/main firefox-locale-en amd64 44.0.1+build2-0ubuntu0.14.04.1 [698 kB]
Fetched 42.7 MB in 46s (913 kB/s)                                              
(Reading database ... 847141 files and directories currently installed.)
Preparing to unpack .../firefox_44.0.1+build2-0ubuntu0.14.04.1_amd64.deb ...
Unpacking firefox (44.0.1+build2-0ubuntu0.14.04.1) over (44.0+build3-0ubuntu0.14.04.1) ...
Preparing to unpack .../firefox-locale-en_44.0.1+build2-0ubuntu0.14.04.1_amd64.deb ...
Unpacking firefox-locale-en (44.0.1+build2-0ubuntu0.14.04.1) over (44.0+build3-0ubuntu0.14.04.1) ...
Processing triggers for gnome-menus (3.10.1-0ubuntu2) ...
Processing triggers for desktop-file-utils (0.22-1ubuntu1) ...
Processing triggers for bamfdaemon (0.5.1+14.04.20140409-0ubuntu1+elementary2~ubuntu14.04.1) ...
Rebuilding /usr/share/applications/bamf-2.index...
Processing triggers for mime-support (3.54ubuntu1.1) ...
Processing triggers for man-db (2.6.7.1-1ubuntu1) ...
Setting up firefox (44.0.1+build2-0ubuntu0.14.04.1) ...
Please restart all running instances of firefox, or you will experience problems.
Setting up firefox-locale-en (44.0.1+build2-0ubuntu0.14.04.1) ...

cat /etc/lsb-release

DISTRIB_ID="elementary OS"
DISTRIB_RELEASE=0.3.2
DISTRIB_CODENAME=freya
DISTRIB_DESCRIPTION="elementary OS Freya"

cat /etc/os-release

NAME="elementary OS"
VERSION="0.3.2 Freya"
ID="elementary OS"
ID_LIKE=ubuntu
PRETTY_NAME="elementary OS Freya"
VERSION_ID="0.3.2"
HOME_URL="http://elementary.io/"
SUPPORT_URL="http://elementary.io/support/"
BUG_REPORT_URL="https://bugs.launchpad.net/elementary/+filebug"

cat /etc/apt/sources.list

# deb cdrom:[elementary OS 0.3.1 _Freya_ - Stable amd64 (20150903)]/ trusty main restricted

# See http://help.ubuntu.com/community/UpgradeNotes for how to upgrade to
# newer versions of the distribution.
deb http://au.archive.ubuntu.com/ubuntu/ trusty main restricted
deb-src http://au.archive.ubuntu.com/ubuntu/ trusty main restricted

## Major bug fix updates produced after the final release of the
## distribution.
deb http://au.archive.ubuntu.com/ubuntu/ trusty-updates universe multiverse main restricted
deb-src http://au.archive.ubuntu.com/ubuntu/ trusty-updates main restricted

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team. Also, please note that software in universe WILL NOT receive any
## review or updates from the Ubuntu security team.
deb http://au.archive.ubuntu.com/ubuntu/ trusty universe
deb-src http://au.archive.ubuntu.com/ubuntu/ trusty universe
# deb http://au.archive.ubuntu.com/ubuntu/ trusty-updates universe
# deb-src http://au.archive.ubuntu.com/ubuntu/ trusty-updates universe

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu 
## team, and may not be under a free licence. Please satisfy yourself as to 
## your rights to use the software. Also, please note that software in 
## multiverse WILL NOT receive any review or updates from the Ubuntu
## security team.
deb http://au.archive.ubuntu.com/ubuntu/ trusty multiverse
deb-src http://au.archive.ubuntu.com/ubuntu/ trusty multiverse
# deb http://au.archive.ubuntu.com/ubuntu/ trusty-updates multiverse
# deb-src http://au.archive.ubuntu.com/ubuntu/ trusty-updates multiverse

## N.B. software from this repository may not have been tested as
## extensively as that contained in the main release, although it includes
## newer versions of some applications which may provide useful features.
## Also, please note that software in backports WILL NOT receive any review
## or updates from the Ubuntu security team.
deb http://au.archive.ubuntu.com/ubuntu/ trusty-backports universe multiverse main restricted
deb-src http://au.archive.ubuntu.com/ubuntu/ trusty-backports main restricted universe multiverse

# deb http://security.ubuntu.com/ubuntu trusty-security main restricted
# deb-src http://security.ubuntu.com/ubuntu trusty-security main restricted
# deb http://security.ubuntu.com/ubuntu trusty-security universe
# deb-src http://security.ubuntu.com/ubuntu trusty-security universe
deb http://security.ubuntu.com/ubuntu trusty-security multiverse
deb-src http://security.ubuntu.com/ubuntu trusty-security multiverse

## Uncomment the following two lines to add software from Canonical's
## 'partner' repository.
## This software is not part of Ubuntu, but is offered by Canonical and the
## respective vendors as a service to Ubuntu users.
deb http://archive.canonical.com/ubuntu trusty partner
deb-src http://archive.canonical.com/ubuntu trusty partner

## Uncomment the following two lines to add software from Ubuntu's
## 'extras' repository.
## This software is not part of Ubuntu, but is offered by third-party
## developers who want to ship their latest software.
# deb http://extras.ubuntu.com/ubuntu trusty main
# deb-src http://extras.ubuntu.com/ubuntu trusty main
# deb http://security.ubuntu.com/ubuntu/ trusty-security multiverse universe main restricted
deb http://au.archive.ubuntu.com/ubuntu/ trusty-proposed universe multiverse main restricted
# deb http://au.archive.ubuntu.com/ubuntu/ jessie-updates main universe restricted multiverse

Reply to @MC Naveen: Error with installing software-center

I've run out of space for this post, so I've put the output for this here.

  • 2
    To install .deb files try "gdebi". sudo apt-get install gdebi – mazienho Feb 7 '16 at 2:26
  • Thanks, that's a workaround for now, but I still want to solve this issue – dspacejs Feb 7 '16 at 9:29
  • Could you please past output of apt-get update && apt-get upgrade? I find it hard to believe that there are not errors. Also output of cat /etc/lsb-release and cat /etc/os-release . Having content of /etc/apt/sources.list would help as well. – morningbird Feb 8 '16 at 18:40
  • Sure, will do @sałe – dspacejs Feb 9 '16 at 11:06
  • @sale I've added the details for those things, check it out – dspacejs Feb 9 '16 at 11:13
2

Simply reinstall your software center :

To uninstall Software Center:

sudo apt-get remove software-center

sudo apt-get autoremove software-center

To re-install Software Center:

sudo apt-get update

sudo apt-get install software-center
  • This failed. I've edited my post and added the error to it, check it out – dspacejs Feb 9 '16 at 11:17
  • It says ImportError: No module named elementary os. That's the same error I had earlier when running software-center... Interesting – dspacejs Feb 9 '16 at 11:19
1

Explanation

The output when you try to launch software-center indicates that there is an error when execute:

/usr/share/software-center/softwarecenter/__init__.py

Its code calls a variable named "DISTRIB_ID" from the /etc/lsb_release file to know what's your OS. You can see the content of this file from terminal:

cat /etc/lsb-release

This content is what it should be, but for some reason (i will comment later), don't work.

A workaround to solve the issue

Let's change the file /etc/lsb-release temporarily:

sudo scratch-text-editor /etc/lsb-release

Go to first line and change DISTRIB_ID="elementary OS" with DISTRIB_ID="Ubuntu"

Now you must reinstall your software-center:

sudo apt-get install --reinstall software-center

When finish, you can replace "DISTRIB_ID" to the old value.

Try to run now software-center. If error appears again, you must set DISTRIB_ID="Ubuntu" permanently. This can make other parts of elementary OS, using lsb_release, stop working.

Reasons for failure

Some changes in your system make unusedful your software center. I have read, not long ago, that Debian has introduced some changes in lsb_release package. I can see a debian repository in your source.list which could cause this issue.

However, both elementary OS and Ubuntu are planning to replace software-center with others applications. You can see more info at:

AppCenter - elementary OS Loki

Gnome Software - Ubuntu 16.04

0

I had an issue with software center opening because I had elementary tweaks installed. I could change the icon pack to an Ubuntu icon set and it worked. If that is the case elementary tweaks is your problem and you have to purge it completely or change the icon pack to something that works.

  • I have encountered this issue with certain icon themes, try changing the icon them back to elementary and see if Software Center opens. – Duarte Mendonca Mar 14 '16 at 0:25
0

Try this solution

Make a backup of /usr/share/software-center/softwarecenter/distro/__init__.py using cp /usr/share/software-center/softwarecenter/distro/__init__.py ~ to backup file. Just in case :)

  1. Run sudo scratch-text-editor /usr/share/software-center/softwarecenter/distro/__init__.py

  2. Go to line 177

  3. Change distro_id= distro_info['ID']" to "distro_id='elementary OS'

    Before edit: `distro_id= distro_info['ID']`
    After edit: `distro_id='elementary OS'`
    
  4. Type in terminal: sudo update-software-center

Hope it works now.

  • Do you have to run update-software-center as root with sudo? – Suici Doga Mar 13 '16 at 13:07
  • @SuiciDoga 'sudo apt-get --only-upgrade install software-center' will be more accurate i guess.. – Nesi Mar 14 '16 at 5:41
0

If you open the "Software & Updates" app and go to the "Other Software" tab, are there four Elementary OS PPAs listed and checked off? If not, does adding them make things any better?

Software & Updates Screenshot

You could also try disabling third-party PPAs. (I had a problem in which I was unable to install software updates until I disabled some PPAs that were causing problems.)

0

Yesterday (the 19th of May, 2016) the issue suddenly disappeared after updating my PC.

I manually used to run this a few times a week, and it looks like the developers finally fixed the issue:

sudo apt-get update
sudo apt-get upgrade
sudo apt-get dist-upgrade
-2

I could fix it with the steps of Nesi and Suici Doga:

  1. Run `sudo scratch-text-editor

    /usr/share/software-center/softwarecenter/distro/init.py`

  2. Go to line 169

  3. Change distro_id= distro_info['ID']" to distro_id='ubuntu'

    • Before edit: distro_id= distro_info['ID']
    • After edit: distro_id='ubuntu'
  4. Type in terminal: sudo update-software-center

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.