I have a brand new Dell Inspiron 15 (5559) laptop with an Intel Skylake i7-6500U CPU and an AMD Radeon R5 M335 graphics card.

Installation of freya 0.3.2 seems to have worked quickly and without problems. However, I cannot shutdown the system without having to use the power button. The problem looks similar to this one

Freya cannot shutdown. init: wait for state plymouth shutdownlightdm killed by TERM signal

because the last line of output is essentially the same. I've tried this fix


which seemed on point, but it didn't work. Now I suspect it might have to do with the graphics card (not sure though) because when I shut down the machine, the following happens:

  • for a split second, there is a graphical glitch - it looks like a rectangular part of the desktop wallpaper is moved and shifted (you can see how it looks like here: elementary OS freezes when trying to reboot / shutdown?)

  • the following screen appears: enter image description here

  • after a split second, the next screen appears: enter image description here

There the shutdown process stops. When I hit the power button, the machine powers down (I don't have to hold the button), and the output looks like this: enter image description here

So far I have used the Xorg open source drivers for AMD cards that came with freya, although the system mistakenly identifies the graphics card as being an AMD Sun XT (Radeon HD 8600M series). When I switched to the proprietary fglrx driver that shipped with the system, I could merely boot into a black screen with a colored line at the top.

Irrespectively of the AMD drivers, when I have a look at the info tab in the system settings, it says "Graphics: Intel Corporation Device 1916 (rev 07)". When I run lspci -nn | grep VGA, the output is:

00:02.0 VGA compatible controller [0300]: Intel Corporation Device [8086:1916] (rev 07)

The problem also occurs at logout, but in this case the process stops at the screen in the first picture.

Any ideas? I'm a bit confused...


Now I have experienced the shutdown/logout to stop at the first graphical glitch without going to the output screens, too. In that case, I have to force quit and power down by holding the power button.


Now there's an error message at startup that seems to be related to the problem. The error description looks like this:

enter image description here enter image description here enter image description here enter image description here

The entry under "Unreportable Reason" (strangely the only one in German) translates to: "This is not an official elementary package. Please remove all third-party packages and repeat the process"


I thought fglrx drivers had been included in the system installation because in the additional drivers tab I had these options: enter image description here

However, searching for fglrx in synaptic revealed that apparently there are no such driver packages installed: enter image description here

So the problem might as well be related to the Intel graphics chipset that apparently is run right now?

  • Thanks for this info - I'm very grateful for all you inputs - i'll have a read though. My HP 350 G2 has a Intel Core i5 so I'm wondering if I should look at the same solution with the intel in mind?
    – Gabriel
    Commented Apr 26, 2016 at 13:07
  • Sorry I have posted this reply in the wrong spot.
    – Gabriel
    Commented Apr 26, 2016 at 14:59

2 Answers 2


I found the solution. The problem is a driver issue with the Intel Skylake graphics chipset. You can solve it by upgrading to kernel 4.3 and upwards. For instructions to update to kernel 4.4 see here: http://ubuntuhandbook.org/index.php/2016/01/how-to-install-linux-kernel-4-4-in-ubuntu/

The only problem is that now there are some random graphical glitches appearing from time to time. It is kind of annoying, but doesn't affect functionality in any way. I guess the drivers for Skylake graphics aren't fully developed yet.


It looks like updating the kernel as described in the abovementioned article bears some risk: http://shnatsel.blogspot.de/2013/12/why-you-should-not-upgrade-kernel-on.html

I couldn't tell because I don't know enough about Linux. See for yourself :)

  • Some hardware needs a new kernel to work. I think the first you should do is update the kernel
    – Suici Doga
    Commented Feb 12, 2016 at 4:20
  • Yeah, especially with NEW hardware ;) I haven't been using Linux for too long so I'm kinda newbie, and with my eight year old MacBook everything worked out of the box, so I didn't consider that immediately. Now I'm more savvy. Learning is a looong process... ;)
    – deesnook
    Commented Feb 12, 2016 at 19:15
  • I also updated my kernel. My computer is about 4 years old and was running hot ,loud and keyboard lights were not working.After upgrading the kernel to 4.4 the problem has been solved
    – Suici Doga
    Commented Apr 10, 2016 at 4:33

OK, so the problem can be solved much easier than installing a new kernel - namely by activating the proprietary drivers for AMD Radeon graphics card (called fglrx). You can choose between fglrx and the open source xorg drivers in the additional drivers tab of the update settings. After fglrx has been installed, the problem doesn't occur anymore.

So it looks like either the Xorg drivers - which are activated by default - do not work with an AMD Radeon M335, or the problem is the Intel Skylake graphics chipset because the AMD card isn't detected/activated at all without the fglrx drivers (this might be the case because when I ran "lspci -nnk | grep "VGA\|'Kern'\|3D\|Display" -A2" the AMD Radeon card wasn't detected at all, but I can't tell for sure).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.