2

After doing a package update I get a 404 error when it's trying to fetch http://ppa.launchpad.net/elementary-os/os-patches/ubuntu/dists/freya/main/binary-i386/Packages

How can I solve that missing dependency?

2

The "FREYA" distribution doesn't exist at ppa:elementary-os/os-patches repository. The correct name is "TRUSTY". To change this you can launch "Software and updates", searching it on Slingshot launcher, or from terminal with the command:

software-properties-gtk 

Once launch it, go to "Other software" tab and search for "elementary os-patches" repository url. Edit it and change the "Distribution" field with "trusty". Accept changes and close software-properties-gtk.

Wait for update the cache and error will be corrected.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.