I am using ElementaryOS on an Acer E5 Laptop with Intel Haswell Graphics and an Nvidia GT840M. The screen of that laptop is 1920x1080 and works fine. At work I connect a second monitor. That one support a resolution of up to 2560x1440. But in the settings it only shows a maximum of 1920x1200. I tried looking in the nvidia x server settings, but there it only shows I have one screen. Does anyone have an idea what I could do to get the native resolution?

  • I tried it in windows too and there it also only shows a max resolution of 1920x1200, but on the win7 pc my colleague uses it shows the native resolution. May it be a problem with my graphics driver(s) ?
    – MrGreenTea
    Commented Feb 3, 2016 at 10:17
  • have you found a solution?
    – user170
    Commented Mar 2, 2017 at 11:26
  • No, it seems like it was a problem with my graphics cards, or at least that's what I assume.
    – MrGreenTea
    Commented Mar 4, 2017 at 11:01

1 Answer 1


Just some questions (since I do not run multimonitor) Have you tried making the second monitor the primary display? If so ... does it show the higher resolutions? Have you tried JUST the second monitor? Does it then show the higher resolutions?

  • I haven't tried setting it as the primary display. I will try both your suggestions on friday, when I am back at the office.
    – MrGreenTea
    Commented Feb 3, 2016 at 10:16
  • Nothing of that helped. I also tried adding a new mode with xrandr --newmode, but that always gives me xrandr: Configure crtc 0 failed
    – MrGreenTea
    Commented Feb 5, 2016 at 12:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.