2

This question already has an answer here:

I updated my Elementary OS like always with the update manager. After reboot no internet anymore. No Wifi and no ethernet worked. I run sudo lshw -C network

*-network DEAKTIVIERT               
       Beschreibung: Kabellose Verbindung
       Produkt: Centrino Wireless-N 2230
       Hersteller: Intel Corporation
       Physische ID: 0
       Bus-Informationen: pci@0000:04:00.0
       Logischer Name: wlan0
       Version: c4
       Seriennummer: 68:17:29:4d:ba:de
       Breite: 64 bits
       Takt: 33MHz
       Fähigkeiten: pm msi pciexpress bus_master cap_list ethernet physical wireless
       Konfiguration: broadcast=yes driver=iwlwifi driverversion=3.16.0-59-generic firmware=18.168.6.1 latency=0 link=no multicast=yes wireless=IEEE 802.11bgn
       Ressourcen: irq:48 memory:e3500000-e3501fff
  *-network DEAKTIVIERT
       Beschreibung: Ethernet interface
       Produkt: RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
       Hersteller: Realtek Semiconductor Co., Ltd.
       Physische ID: 0
       Bus-Informationen: pci@0000:05:00.0
       Logischer Name: eth0
       Version: 07
       Seriennummer: 28:d2:44:0c:4b:24
       Größe: 1Gbit/s
       Kapazität: 1Gbit/s
       Breite: 64 bits
       Takt: 33MHz
       Fähigkeiten: pm msi pciexpress msix vpd bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd 1000bt 1000bt-fd autonegotiation
       Konfiguration: autonegotiation=on broadcast=yes driver=r8169 driverversion=2.3LK-NAPI duplex=full firmware=rtl8168e-3_0.0.4 03/27/12 ip=192.168.178.51 latency=0 link=yes multicast=yes port=MII speed=1Gbit/s
       Ressourcen: irq:43 ioport:2000(Größe=256) memory:e2404000-e2404fff memory:e2400000-e2403fff

It says: DEAKTIVIERT -> deactivated. I tried to put

auto wlan0
iface wlan0 inet dhcp
auto eth0
iface eth0 inet dhcp

into /etc/network/interfaces. But then Freya didn't start. I chose an older kernel version to start (59 instead of 60) and the internet went well. But if I start Freya again the normal way it will be gone again.

I have a Lenovot Think-Pad E531 Till today Freya was working super fast and great. Hope somebody can help me with this.

I also tried to downgrade the network iface Änderungen für network-manager-dbg Versionen: Installierte Version: 0.9.4.0-0ubuntu3 <- installed version Verfügbare Version: 0.9.8.8-0ubuntu7.2 <- version to be installed

marked as duplicate by Lewis Goddard Jan 30 '16 at 12:31

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • Was the Linux kernel updated ? I think that's the reason for the problem. Sometimes i get the same problem. Try to get on boot into "advanced boot settings" in Grub and start Elementary OS with an older kernel version. – pdunker Jan 30 '16 at 9:46
  • Try modprobe r8168 to enable ethernet. Have you connected after this? – bitseater Jan 30 '16 at 9:54
  • I already started the system with an older kernel but this just helps till I start again the normal way. modprobe r8168 telss me FATAL: Module r8168 not found. – Informatic0re Jan 30 '16 at 10:00
  • I am now back on kernel 60 without working internet. I added just auto eth0 iface eth0 inet dhcp to my interfaces and I was able to boot. – Informatic0re Jan 30 '16 at 10:09
2

Check out my post here: http://goo.gl/y2gpFd it should help.

  • thanks. I needed to remove auto eth0 etc., than everything worked well again. How can I ignore the updates in Synaptic? (I am linux noob) – Informatic0re Jan 30 '16 at 11:56

Not the answer you're looking for? Browse other questions tagged or ask your own question.