2

I just did a fresh install of elementary OS Freya. In Software & Updates, all these boxes are unchecked:

  • Important security updates (trusty-security)
  • Recommended updates (trusty-updates)
  • Pre-released updates (trusty-proposed)
  • Unsupported updates (trusty-backports)

software & updates

I can't check them, for some reason. When I check one of them, and enter my password, it immediately unchecks itself again. Even after manually updating and restarting.

Then, when I click X, I get this message (every single time):

the information about available software is out-of-date

I click Reload, it downloads something, it closes. I open Software & Updates again, and all of this happens again.

6
  • Just a question mind you ... Did you set yourself up as an administrator? I would guess this type of behavior if you were not one. – George Barbaz Feb 3 '16 at 16:53
  • @lphd Have you tried my answer – Suici Doga Feb 4 '16 at 1:56
  • I'm experiencing the same issue. I am an administrator on my computer. I noticed the problem because I saw an exclamation point in the indicator area. When I click the exclamation point, I see a message: "The update information is unavailable. This may be caused by network problems or by a repository that is no longer available." – Ryan DeBeasi Feb 4 '16 at 2:47
  • Same issue here on a brand new Dell Laptop - interestingly, the problem only occurred randomly after the third fresh install (I was trying out stuff). – deesnook Feb 5 '16 at 21:13
  • Could it be related to this problem (duplicate entries in the software sources)? elementaryos.stackexchange.com/questions/2453/… On my machine, both problems occurred simultaneously – deesnook Feb 5 '16 at 23:49
0

Try opening the "Software Updater" app instead of "Software & Updates". Does a list of updates appear? (After a fresh install of Freya, you should see a bunch of updates.) If you click "Details of Updates", do you see anything other than "Elementary Base"? If so, those are most likely from trusty-updates or trusty-security.

If you answered "yes" to both of those questions, then your updates are working properly, and the Software & Updates app has a UI bug. It's frustrating for sure, but I believe this app is slated to be removed in the next version of Elementary and replaced with Elementary's own software center.

The good news is that unless you plan to add third-party PPAs, you can generally ignore the "Software & Updates" app. The fact that Ubuntu has a Software Center and two different "Software Update" apps drives me bananas, personally! :)


I'm experiencing this issue, and Software Updater is telling me I have no updates. As far as I can tell, third-party PPAs that I added are misbehaving, and Software & Updates is doing a poor job of explaining exactly what has happened. Here's how I fixed it:

  1. Open the "Software and Updates" application.
  2. Go to the "Other Software" tab.
  3. Look for third-party PPAs, and disable them. The third-party ones will have a URL (not a name such as "Recommended updates"), and that URL won't start with http://ppa.launchpad.net/elementary-os.
  4. The checkboxes in the updates tab still won't check. This is totally fine.
  5. Run the "Software Updater" application. You should now be able to get updates. If you click "Details of Updates", you can see the actual packages that will be updated.

Optionally, after things are fixed, go back and re-enable PPAs one by one and see if anything breaks.


Possibly related: this bug in Launchpad.

Edit: Here's an Elementary ticket for this bug. Looks like the bug will be fixed in 0.4.

Not the answer you're looking for? Browse other questions tagged or ask your own question.