2

I just downloaded elementary OS and did a fresh install and noticed that apps have no menus (File, View, Edit, etc.).

So I searched on Google and found something to add a "Global Menu" similar to OS X, but it didn't work, so I uninstalled it. I still have no menus on any application, not with a fresh install and not with that link I found.

I'm on elementary OS 0.3.2 Freya 64-bit

(I don't care if they show "globally" at the top or inside of each window, I just want app menus to show)

no_menus

  • I will try to write an actual answer later, but elementary apps don't have "File, View, Edit, etc." menus, and neither do apps like Chrome. – Lewis Goddard Jan 27 '16 at 20:39
2

elementary apps don't have menu bars.

In fact, most modern apps don't have menu bars. Chrome, GNOME, elementary, Metro apps on Windows 10, iOS and Android.

Saving is done automatically, exiting is the same as closing, and any other functionality that might be missing is usually in a more accessible button, maybe a popover or slide.

  • 3
    I'm trying to do something as simple as change settings on a terminal emulator application or a file manager like nemo but there is no menu and no button to press to reach it. Other Linux distributions have menus on the same applications I'm trying, even Chrome. I've only experienced this issue with elementary. – Omar Bahareth Jan 27 '16 at 22:13
  • If you are talking about the terminal or file manager that comes with elementary, then your experience is correct. Chrome has never had a menubar in any system I have used, although in it's settings you can find a "Use system title bar and borders" that might add them on certain systems. Third party applications that experience issues should be reported to their developers. – Lewis Goddard Jan 28 '16 at 1:50
  • I even tried Terminator, Nemo, and Konsole, they don't have menus only on elementary. How can it be a problem with third party applications if they show on every other distro I've tried? – Omar Bahareth Jan 28 '16 at 11:40
  • 2
    You probably have still something left with this global menu stuff... – Djax Jan 28 '16 at 16:56
  • 1
    This is a ridiculous design choice. Almost every program has some often used options and operations, and everyone who has used a computer in the last 30 years expects there to be an application menu. I'm now struggling with something so simple as switching from continuous to per-page view in the PDF-viewer. This is not helping users at all. – James Apr 4 '17 at 13:17
2

Unfortunately this functionality is, I believe, deliberately left out of eOS. And your correct that almost all other Linux distributions do have it. Why I don't know? Why don't they inclue a minimize button on their window manager by default? I don't know. But this is how "Gala"(eOS window/display manager) works. Also if you install Elementary Tweaks Tool, you'll notice that some applications use GTK+ decorations while others use Metacity. The one's that are using GTK3+ (such as Chrome) will have a list of options when you right-click the empty header bar, such as what workspace you'd like to move them to/always on top. I agree this approach is not the most intuitive for their target demographic, but what are you gonna do?

1

I would like to refresh this topic. Do you know the way how to uninstall system pantheon top panel (this one on the top) and replace it with one another who supports global menus? I would not to deliberate with is it good approach or not on general. I am a developer who writes code with InteelIJ on 13" screen. Putting this bar to the top gives me one more line of code that's a lot on this screen. I wouldn't argue about user experience because I'm not into it. Thank you in advance for any suggestions.

0

elementary OS doesn't do anything one way or another about menubars in 3rd party apps. If you've installed some piece of software to add global menus, that is probably still removing the menubars from these apps. Make sure you completely remove anything related to global menu.

  • I installed global menu because I had no menu bars in apps on a fresh install. – Omar Bahareth Jan 28 '16 at 20:38
  • 1
    @Leaf As Lewis indicated, none of the default apps have menubars and many 3rd party apps don't either. However "global menu" software may be causing you to experience this issue with 3rd party apps which are supposed to have menubars. – Daniel Foré Jan 28 '16 at 22:14
  • I wiped the hard drive clean and did another fresh install and the issue is still there without installing anything that alters menus. As I've said before, this issue is not present in other Linux distributions I have tried. – Omar Bahareth Jan 30 '16 at 15:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.