1

I tried posting something akin to this on SuperUser but I think it's too specific to elementary OS to be helpful.

I did the following:

  1. Inserted USB into my drive
  2. Inserted cd with burned iso
  3. Booted computer to Disk Drive which started elementary
  4. Started install process and chose "something else"
  5. Installed elementary to /dev/sdb (USB)

All looked well for a while. I rebooted with the USB still inserted and I got the normal grub menu which (after 10 seconds) booted to Elementary, great!

So I rebooted again, and removed the USB. Now I just get a grub command prompt akin to grub>.

If I enter the exit command, it echos "boot ubuntu" and takes me to the BIOS device selector.

Now when I click the Disk drive, rather than it booting Windows, I see:

ubuntu
Windows Boot Manager
Ubuntu

I was expecting that if I selected to boot from the USB, I would get the grub menu, but now I always get it regardless.

What can I do to force grub to boot to Windows if the USB is not inserted? (I've already configured the USB to boot to whatever I want when it's inserted, but

  • Is this a UEFI PC – Suici Doga May 6 '16 at 5:27
  • "Yes it is. I've confirmed this in BIOS mode settings." – Reisclef Feb 7 at 16:31 – Reisclef May 9 '16 at 9:59
  • Only UEFI firmware has a OS selector – Suici Doga May 9 '16 at 10:29
1

Boot into elementary and open the terminal and type :

sudo software-properties-gtk -e universe && sudo apt-get update 
sudo apt-get install mbr
sudo install-mbr /dev/sdX

Replace sdX with the correct disk device which I have think is sda

If you cannot boot elementary on the USB. Boot to the live USB / CD and type sudo grub-install /dev/sdb replacing sdb with the USB drive device (which you say is sdb)

  • So just to confirm before I run this, this is effectively writing a master boot record to the sda that (I take it) grub would use to boot from? I guess that explains why I get the grub> prompt at the start. What is the risk of doing that? Would it corrupt any windows MBR? – Reisclef Jan 27 '16 at 18:35
  • I've since read through some online sites and backed up the mbr on dev/sda using elementary, just in case! However, when I run the first command in your answer, I get "The --enable-component/-e command-line switch has been deprecated. Instead of 'software-properties-gtk -e multiverse' you can use 'add-apt-repository multiverse'". Is this necessary before running the second and third commands? – Reisclef Jan 27 '16 at 19:16
  • @Reisclef Yes it is. You can use the new add-apt-repository – Suici Doga Jan 28 '16 at 10:20
  • Darn, I still have the same effect (boot goes to grub> command line) after running "sudo add-apt-repository universe && sudo apt-get update", "sudo apt-get install mbr", and "sudo install-mbr /dev/sda". Thankfully, I can still boot to Windows the same way by entering "exit" at boot, and then selecting Windows Boot Manager in BIOS. Thanks for your help so far, any other suggestions? – Reisclef Jan 28 '16 at 19:13
  • Follow these instructions help.ubuntu.com/community/RestoreUbuntu/XP/Vista/7Bootloader – Suici Doga Jan 29 '16 at 1:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.