4

I have just installed Freya. On the fresh boot it always finds my WiFi and connects to it. But, after some time it drops. Then, it never connects to the connection again until restarting the laptop. I saw 3-4 bugs relating to the same issue on the bug-tracker.

What is the problem here? I love elementary OS but without internet I can't do anything. Does anyone have any solution to this? I have already tried this.

  • What brand and model of computer do you have Elementary OS installed on? – user3906 Jan 27 '16 at 5:00
  • I should thank a million times to TrigonaMinima for writing that answer. This solved the issue for me on Freya and i have the same realtek rtl8723be driver so kudos! – Shahzaib Rahim Sep 1 '16 at 12:41
  • I had the same wireless card and so far TrigonaMinima's answer seems to have helped – user6363 Sep 19 '16 at 2:16
1

After getting frustrated with Freya, I installed Linux Mint, thinking that the problem was OS dependent, but I faced the exact problem there as well. I was able to solve it as follows.

Step 1: Update the kernel

I don't think this step is necessary, but I also had the problem of pixelated logo screen before the login screen. Updating to the latest stable kernel rectified that. You can get the deb files from here. Just download the files and do this-

sudo dpkg -i *.deb

Step 2: Patching the linux kernel

My laptop has Realtek wireless device, and as I discovered, it's a common problem between linux kernel and Realtek devices. Get the drivers from https://github.com/lwfinger/rtlwifi_new. Download the project and-

cd ./rtlwifi_new
make
sudo make install
sudo modprobe <driver-name>/<driver-name>.o

<driver-name> can be found in the output of the following command, under the Wireless interface in the configuration field.

sudo lshw -C network

Replace <driver-name> with the driver name, like in my case it was - rtl8723be.

  • If this helps someone, then do comment. I can then mark this as the answer. I didn't try this on Freya. – TrigonaMinima Feb 12 '16 at 8:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.