2

I've got an azerty keyboard.

Since I installed Freya, the keyboard in the greeter is in qwerty, and no way to change it. This is really annoying.

It seems that this bug has been encountered since the beginning of Freya, and hasn't be solved. I found several forum threads talking about :

And none of them gave me a succuessful answer.

My colleague installed Freya some time after me, and he have the same problem.

Things I've done : - put the whole system in french using system settings

Things I've tried, without any success :

  • checked /etc/default/keyboard
  • added a section in Xorg conf
  • installed lightdm-gtk-greeter (keyboard still in qwerty).

[new] Installing ubuntu-greeter, I got an azerty login (see my comment on the answer below). So the problem resides in the difference between ubuntu-greeter and pantheon-greeter/lightdm-gtk-greeter.

my /usr/share/X11/xorg.conf.d/10-evdev.conf :

Section "InputClass"
    Identifier "evdev keyboard catchall"
    MatchIsKeyboard "on"
    MatchDevicePath "/dev/input/event*"
    Driver "evdev"
    # set keyboard to french
    Option "XkbModel" "pc105"
    Option "XkbLayout" "fr"
    Option "XkbVariant" "oss"
EndSection

my /etc/default/keyboard

XKBLAYOUT=fr,us
XKBVARIANT=,oss,

(And probably many others I don't remember. But just ask me to try something, and I'll try if you think it can change something)

"Change your password", "use auto-login", or any other such answer will be disregarded; I'm really looking for understanding what's going on, and getting the correct configuration.

At the contrary, any question will be answered, and any :

  • reference to some relevant forum/bug
  • suggestion for solving this problem,
  • indication of which log files can be relevant,
  • indication of which source files can be relevant (I can fix and recompile a package if necessary)

, will be welcome.

  • can you add specs from your machine? maybe is a drivers problem.. – td18 May 18 '16 at 3:13
  • Thanks for your interest. What can I tell : its a DELL computer, with a wireless keyboard and mouse. If you have commands you want me to run, just ask. – Pierre-Olivier Vares May 18 '16 at 8:45
2

I had same issue. Some people says to re-configure keyboard

sudo dpkg-reconfigure keyboard-configuration

but i did not work for me until I reconfigure LighDm :

sudo dpkg-reconfigure lightdm

Now it works fine for me

  • Thanks for the answer. I did it, but it still doesn't work. – Pierre-Olivier Vares Mar 14 '16 at 8:16
1

As an alternative, I've been able to have a correct keyboard layout option switcher by removing pantheon-greeter and installing unity-greeter Not as pretty, but a workaround good enough if you really need to be able to switch between keyboard layouts at the login screen ...

  • Thanks, it works. Except that the password field text is invisible !? I retain the idea and will try with other greeters. – Pierre-Olivier Vares May 18 '16 at 9:01
  • Trying to install lightdm-gtk-greeter doesn't solve the problem : the selected keyboard is "fr_FR", but it's a qwerty configuration. – Pierre-Olivier Vares May 18 '16 at 9:18
  • (Note that I don't even need to switch between keyboard layouts, just to have the same layout as I always use.) – Pierre-Olivier Vares May 18 '16 at 9:38
  • Yes password field was invisible, I never found a solution to that as I went back to ubuntu ... Also if it helps, I saw that the layouts, in my case, was set to the last one I selected during my session. For example, if user A add FR and B had US, selecting A was properly using FR for the login, and B the US ... still messy though. – abo Jun 28 '16 at 1:40
0

I used to type my password in qwerty.

As of today, I didn't succeed in login... until I type my password in azerty, and it works !

So, I'm supposing there was a recent upgrade (I don't log in every day - only where there's an upgrade needing a reboot) that solved the problem.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.