3

I am running elementary OS 0.3.2 Freya (64-bit).

Under "Power" in "System Settings", the "Turn off screen when inactive" is not working. I have it set to 10 minutes, and when the timer is up, instead of the screen turning off it displays a bunch of vertical lines composed of the colors from my desktop background, at full brightness. I had to run an "unburn/stuck pixel" video to retrain my lcd since the vertical lines "burned in" slightly. Fortunately there was no lasting damage.

Is there a fix for this setting? Also, there is no screensaver setting with this distribution, and I cannot find one under "software Center". I would like one as a backup due to the inactive screen issue. Any suggestions?

  • I suppose elementary OS is not as well supported as other distros built on Ubuntu. Should I simply dump elementary and reinstall Ubuntu MATE? – Kit Jan 23 '16 at 2:43
  • 1
    What kind of screen is this. See howtogeek.com/128644/… .LCD screens do not burn-in.Maybe you have a CRT – Suici Doga Mar 11 '16 at 2:04
1

You have to create a small Shell Script. Create an empty file and then open it.

Paste:

#!/bin/bash xset s off xset -dpms

Save file. Open terminal and prompt: chmod +x filename (where "filename" is the name of that file) then prompt: gnome-session-properties click add and browse your new file.That's it. After restart you can type in terminal xset q to make sure that DMPS is Disabled.

0

I have this same problem with screen saver. After 15 minutes is turning my screen black and is logging out. I try turn of in gnome system settings from user privileges, but it did't worked. I try install external program "light-locker-screen" but i have problem with modules from python.

Then I come up with idea that I will run command from terminal as super user, and run gnome-control-center. sudo su gnome-control-center

and go to power, there was set "turn of screen when not active" to 15 minutes, and i changed to never, and also i go to security & privacy, and there from Locking I turn of "lock on sleep" and "lock after screen turns of"

I think that normal user even if will switch of that options will be not affected, because super user have greater privileges. And maybe solution is to do that in super user mode?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.