0

I was instructed that by adding the line OnlyShowin=Pantheon in the .desktop file of an app, would make it show on Slingshot menus. I did that with gufw (the firewall app), but it didn't happen. Please advise on what I'm missing. The .desktop file (located in /usr/share/applications) is as follows:

[Desktop Entry] 
Version=1.0 
Name=Firewall Configuration 
Comment=An easy way to configure your firewall
Categories=GNOME;GTK;Settings;Security;X-GNOME-Settings-Panel;X-GNOME-SystemSett‌​ings;X-Unity-Settings-Panel;X-XFCE-SettingsDialog;X-XFCE-SystemSettings;System 
Exec=gufw 
Icon=gufw 
Terminal=false 
Type=Application 
X-GNOME-Settings-Panel=gufw 
X-Unity-Settings-Panel=gufw 
X-Ubuntu-Gettext-Domain=gufw
  • Can you please post the contents of the .desktop file so we can check and see what might be missing? Thanks! – Ryan DeBeasi Jan 20 '16 at 13:59
  • This is the content: [Desktop Entry] Version=1.0 Name=Firewall Configuration Comment=An easy way to configure your firewall Categories=GNOME;GTK;Settings;Security;X-GNOME-Settings-Panel;X-GNOME-SystemSettings;X-Unity-Settings-Panel;X-XFCE-SettingsDialog;X-XFCE-SystemSettings;System Exec=gufw Icon=gufw Terminal=false Type=Application X-GNOME-Settings-Panel=gufw X-Unity-Settings-Panel=gufw X-Ubuntu-Gettext-Domain=gufw – William Pabón Jan 20 '16 at 19:57
  • Sorry, I don't know how to format above comment to show appropriately. – William Pabón Jan 20 '16 at 19:59
  • No worries! I probably should've asked this before, but where is the .desktop file located? – Ryan DeBeasi Jan 20 '16 at 20:11
  • /usr/share/applications – William Pabón Jan 20 '16 at 23:37
1

Remove OnlyShowin=Pantheon from the .desktop file. I didn't have to add OnlyShowin=Pantheon to get my .desktop file to show in Slingshot.

|improve this answer|||||
  • I added OnlyShowin=... because the app didn't show in Slingshot. – William Pabón Jan 20 '16 at 19:55
  • Does It work without OnlyShowin=... – Suici Doga Jan 21 '16 at 1:33
  • Right now the desktop file doesn't have OnlyShowin=... and still it doesn't work. – William Pabón Jan 21 '16 at 15:43
  • Remove X-GNOME-Settings-Panel=gufw X-Unity-Settings-Panel=gufw X-Ubuntu-Gettext-Domain=gufw from the .desktop file – Suici Doga Jan 22 '16 at 9:05
  • Sorry. Your suggestion didn't solve my problem. Gufw still doesn't show on Slingshot menus. – William Pabón Jan 23 '16 at 14:18
1

If you place the .desktop file in ~/.local/share/applications instead of /usr/share/applications, does that fix the problem?

From the Human Interface Guidelines:

Users may create their own launchers by putting .desktop files in ~/.local/share/applications.

|improve this answer|||||
  • Sorry. Doing your recommendation doesn't solve the problem. I am studying Mario's solution, but it seems a little complicated, an arises questions. I will comment on them shortly. Thanks. – William Pabón Jan 21 '16 at 19:14
0

If what you are trying to achieve is to show an application or program in the Slingshot menu, I have done it by following the instructions located here.

Which in short are:

sudo apt-get install --no-install-recommends alacarte

Then

sudo scratch-text-editor /usr/share/alacarte/Alacarte/MenuEditor.py

There you have to replace the string applications.menu with pantheon-applications.menu (all occurrences).

Finally, from the terminal: sudo alacarte

And there, you're done. You can now add shortcuts to the Slingshot menu and personalize categories.

|improve this answer|||||
  • Mario, thanks for your suggestion, and I'm considering it. But, still I would like to understand the problem in this particular app (gufw). Before this one, I have installed like five or six different apps from the Software Center and in none of them I had to do anything for them to show on Slingshot in their corresponding category. I tried to identify if there was a distinctive characteristic on the desktop file by comparing it with the others, but I couldn't find any. Your additional thoughts will be appreciated. Tks. – William Pabón Jan 22 '16 at 0:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.