I have five HDD in my machine: 1. SSD 120 GB (SATA) 2. HDD 400 GB (ATA133) 3. HDD 500 GB (SATA) 4. HDD 500 GB (SATA) 5. HDD 320 GB (SATA)

On SSD drive I had Windows 10 instaled. I decided to remove windows and install Elementary OS, but when I run installer (from USB pen) it doesn't see SSD hard drive. When I chose "try elementary" I can see SSD but when I try to install I can chose all HDD but no SSD :/ I change configuration in BIOS from "Native IDE" to "AHCI" but it doesn't change anything. So I decide to remove all data from SSD, and format it as ext4, but this also didn't help.

At the end I decided to change SATA port for SSD but as you guessed it didn't worked.

Anyone have some idea what can be wrong?

  • When you had Windows on the SSD, was it Bitlocker encrypted?
    – user3821
    Jan 20, 2016 at 9:17
  • If you start the Live system, open a terminal and type cat /proc/partitions, is the SSD drive in the list?
    – Artisan72
    Jan 20, 2016 at 11:41

3 Answers 3


Thanks all of you for help. Problem solved. This is how I manage it: I remove all partition from SSD and I created newone ext4 partition, but I still couldn't install elementary on this disk. Once I reboot my PC I forgot to boot it from USB drive. I saw Windows logo and after a moment message shows that my windows is broken and need to be repaired. Then enlight me that in MBR there is information that on this disk Windows 10 is installed and propably Elementary installer prevent me to install it on this disk because of this. So I started elementary from USB drive, start gparted and recreate partition tabele (this errase mbr from HDD). After that I could install Elementary OS :)

Right Now I'm testing elementary as my primary OS. If if it meets my expectations few $ will be transfeered from my account to elementary support :D

  • Mark as answer.
    – Suici Doga
    Mar 20, 2016 at 4:53

I didn't encrypt any of my hard drives. When I run "Try Elementary" I have full access to SSD it is found in system as sda. I cen read it, write it but when I try to install Elementary OS there is no SSD on the list. What is interesting I see SSD in option "Device for boot loader instalation"

  • can you make a photo of the HDD list when you try to install it and post it?
    – Artisan72
    Jan 20, 2016 at 18:13

I've found a similar question here. Maybe the answer there can help you.

Cannot choose HDD at installation

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.