4

I don't get any image previews in Pantheon Files.

I already did the chown of the .thumbnails folder as suggested in various other places, but that didn't help. The thing is: I do get previews for PDFs and Fonts. I also tried the following: I put the tumbler.rc from /etc/xdg/tumber into ~/.config/tumbler and set PDF disabled to true, with the effect that there were in fact no PDF thumbnails generated anymore. So somehow tumbler does work, and even reads the tumbler.rc correctly and can write to the .thumbnails folder. Just not for image previews (not JPG nor PNG etc.).

I am by far no linux expert, so I am pretty much stuck now how to proceed.

Btw, on my laptop everything works fine, just not on my workstation. I did update, upgrade, dist-upgrade etc. on both of them.

Edit: Just saw that I also get previews for BMPs.

  • Just made a new observation: Once I edit the name of a PNG in Files, I do get the preview. I suppose that hints at some rights or ownership crap? Any ideas for what I should look out for? – sebastian_k Jan 22 '16 at 14:12
  • I would like to add to this problem that the thumbnails work perfectly fine when using nautilus. I also tried with uninstalling and reinstalling tumbler-plugins-extra as well as pantheon-files. Still no success. What else can I try? – sebastian_k Jan 25 '16 at 13:01
1

I assume you are using Freya stable version (Files r1980)? Do the thumbnails show if you press the reload button?

One thing that can stop thumbnailing working (at all) is if you show a folder containing a .webm file; this seems to cause tumblerd to hang. The latest version of Files does not suffer from this as it uses a newer version of tumbler. (see bug 1532512). To escape from this navigate away from the offending folder, kill the tumblerd then reload the folder (without .webm file).

Also, Files will not thumbnail files situated on a network folder.

However, using r1980 version I do not have any trouble with thumbnailing jpg files in a local folder (without .webm).

  • Hey! Yep, I have updated and upgraded everything, pantheon-files is at 0.2.4. Reloading does not help, I do not have any .webm files whatsoever, and it also does not work on local drives. I can make files show the thumbnails if I edit the name of a file. But as soon as I reload the folder the thumbnail goes away... – sebastian_k Jan 27 '16 at 10:35
  • Oh, and I also do get previews for BMPs, TGAs, even JP2s. And what's even weirder: When I rename a .JPG to .TGA, it shows the thumbnail, even when I reload the folder it still works. – sebastian_k Jan 27 '16 at 10:42
  • I will have to install a completely vanilla version of Freya to check this out, as I do development and have the daily repositories installed, so I probably have later versions of some libraries even when running r1980 of Files. e.g. my tumbler version is 0.1.30 – Jeremy Wootten Jan 27 '16 at 14:53
  • Thanks so much for looking into this! Thing is, it works fine on my other computer, so most likely it is something I have done on this system, which causes the error. I just have no clue how to search for this error. For example, could it be issues with some image format libraries? Btw, I have also this version of tumbler installed: tumbler 0.1.30-1ubuntu1 – sebastian_k Jan 27 '16 at 14:57
  • after using Freya for quite sometime, then I stumbled this issue, any news or workaround to fix this? – aditia Feb 8 '16 at 13:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.