(The hyperlinks are pictures I took)

I had Windows 10 installed on my computer (which is a Lenovo Z70) and I installed elementary OS but Grub2 is not recognizing the OS, actually none of them.

If I type exit then I get to the Boot Manager and I can find Windows but not Linux.

For the installation I created a swap area (2GB) and an Ext4 file system.

I'm sorry for this mess, the pictures are too big to upload.

Thanks in advance,

  • Images aren't working (link not found) – Suici Doga Mar 20 '16 at 10:06

Maybe you had use and old freya ISO version? In 0.3 and 0.3.1 there were errors with grub-efi installation.

I will to assume you have create a 350mb efi boot partition on install of elementary, if not, you should reinstall creating it as the first partition (primary, 350mb, type "EFI boot")

Run elementary's live-CD, connect to internet, open terminal and do this:

sudo add-apt-repository ppa:yannubuntu/boot-repair && sudo apt-get update && sudo apt-get install -y boot-repair && boot-repair

once it finish and boot-repair open, click on bottom left to open advanced settings, on main option tab, click on reinstall grub. In Grub location tab, check you have selected /efi/boot separate partiton selecting elementary boot efi partition. Click on apply, you have to manually reinstall grub following instructions. Once it finish, open again the program and run recommende repair. It should repair grub

  • Do you have 2 accounts? – Suici Doga Mar 20 '16 at 4:28

This happens when UEFI CSM is enabled in UEFI firmware settings and causes GRUB2 to be installed to the MBR.

First enter UEFI firmware settings by holding down shift while clicking restart in Windows


Click on the troubleshoot tile


Now click Advanced Options and then UEFI firmware settings.


Then disable UEFI CSM (Compatibility Support Module) and install elementary OS again.

If it still fails try REFIND bootloader (I will add instructions)


I had a similar problem with my laptop. It turned out to be the BIOS firmware in UEFI mode. Switching to legacy mode solved the issue. Hope it works for you too.

The downside of this approach:

1) although elementary os boots just fine, windows 10 does not

2) slower for modern motherboards.

  • Why should I switch back to ancient BIOS.Also doing this breaks Windows 10 – Suici Doga Mar 20 '16 at 4:26
  • Because it solved the problem for elementary OS, which is what this site is about. If it solved the problem, it is a valid answer to this question, even if it is not the best one. – João Matos Mar 20 '16 at 8:54
  • Legacy boot increases boot time on new motherboards – Suici Doga Mar 21 '16 at 8:31
  • I understand, but it boots elementary os successfuly, hence it counts as a valid solution. I'll edit the answer to add your feedback. – João Matos Mar 21 '16 at 8:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.