1

I screwed up after an update (probably from a ppa of another distribution from which I wanted the internet browser...) so when I log in to the account, I only have the background image and the desktop files. No dock, panels, applications, etc. Tried to boot with the extra features to check packages and filesystem but it did nothing.

Any hint on how to revert this? I'm currently on windows (I have dual boot). ALthough i can access personal files, I have nothing to work with.

Thanks in advance!

  • what is the browser? – Ravan Jan 15 '16 at 11:51
  • I added temporarily the trisquel ppa to get the icecat directly, I turned off the updates it showed but I guess at least one was kept :/ – AntonioS Jan 15 '16 at 22:51
1

As mentioned at https://askubuntu.com/questions/578258/i-cant-install-icecat-on-ubuntu-12-04 there is a warning about this ppa that it is for older versions of ubuntu.

To remove that ppa press CTRL + ALT + F1 while on the login screen and type your username and password to enter TTY.Typesudo add-apt-repository --remove "deb http://mirror.fsf.org/trisquel/ toutatis-updates main" and after that type sudo apt-get upgrade.

After it is finished exit TTY by pressing CTRL + ALT + F7 and reboot the system and login. Your installation should be running now.

If this doesn't work open TTY (do you remember :) and login then type sudo apt-get install ppa-purge.After that type sudo ppa-purge "deb http://mirror.fsf.org/trisquel/ toutatis-updates main" and ffter that command is finished type sudo apt-get upgrade then press CTRL + ALT + F7 to exit TTY then reboot and login. Your ELementary OS should work now

  • I haven't seen reference to the TTY for a long time! Thanks for the answer, hadn't seen any similar answer while searching for the problem. – AntonioS Jan 18 '16 at 12:05
  • I haven't seen reference to the TTY for a long time! Thanks for the answer, hadn't seen any similar answer while searching for the problem. I did part 1 - no changes I went for part 2 (and repeated to make sure there were no mistakes) and I got the following error: updating packages lists W: Failed to fetch http://ppa.launchpad.net/versable/elementary-update/ubuntu/dists/trusty/main/binary-amd64/Packages 404 Not Found W: Failed to fetch http://ppa.launchpad.net/versable/elementary-update/ubuntu/dists/trusty/main/binary-i386/Packages 404 Not Found – AntonioS Jan 18 '16 at 12:18
  • continued output: ` E: Some index files failed to download. They have been ignored or old ones used instead. Warning: apt-get update failed for some reason ` – AntonioS Jan 18 '16 at 12:20
  • I tried to add the ppa it mentions that were not found but it says invalid (using sudo add-apt-repository (...)) I checked again the methods you mentioned but I still get no changes Thanks a lot in advance! – AntonioS Jan 18 '16 at 12:36
  • Is your system working now? – Suici Doga Jan 18 '16 at 12:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.