2

Elementary has been running very well on my Dell XPS 13 9343 for months, but today I decided to try to scale up the display a bit because it was a little hard to read text. I entered the following command:

gsettings set org.gnome.desktop.interface scaling-factor 21

Instead of 2.1 (also, scaling with floats didn't work, only integers like 1, 2, 3, etc).

The problem is that now, logging in crashes Pantheon before I can launch a terminal window, let alone enter the commands to reset scaling to 2, and kicks me back to the login screen. Cntl-alt-F1/F2/etc. does not bring up a shell like it does in Ubuntu, which would allow me to edit it without launching Pantheon. Also, going into recovery and getting a root shell won't allow me to change the setting because the system files are read-only in recovery.

Am I missing some easy way to bring up a shell from the login screen? How can I repair this? Also, is it possible to scale the display by %? 2 is too small and 3 is too large.

Thanks

Edit to clarify: Pantheon launches with the huge menu bar across the top. Super+Space opens the app launcher, then the session crashes. If I don't do anything, the display shows only the wallpaper (properly scaled) and then the whole computer freezes, requiring a hard shutdown.

Update: I can pull up TTY1 with Ctl-Fn-Alt-F1, but setting gsettings from there brings up the error: dconf-WARNING: failed to commit changes to dconf: Cannot autolaunch D-Bus without X11 $DISPLAY

2

After tons of troubleshooting, the following solved it:

  • Log in as normal. Immediately after logging in as the affected user bring up TTY1 with Ctl-Fn-Alt-F1
  • Enter export DISPLAY=:0.0

  • Set gsetting as usual (gsettings set org.gnome.desktop.interface scaling-factor 2)

  • I couldn't find a way out of TTY1, so I just did sudo service lightdm restart
  • When you are in TTY you can get back to GUI using Ctrl+Alt+F7 (Ctrl+Alt+fn+F7 if fn key is needed to use the function keys) – shrestha_aj Jan 15 '16 at 17:12
  • Thanks--that worked in Ubuntu, but for some reason it doesn't for me in Elementary – RoboRob Jan 16 '16 at 16:44
  • Well it should... works for me :) – shrestha_aj Jan 16 '16 at 17:07
  • If that is not working, then you may need to report a bug. – RolandiXor Feb 17 '16 at 19:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.