5

I work a lot in terminal, and am not a fan of having new tabs and new windows opening my previous working directory. I would like to change pantheon-terminal to open my home directory each time.

I found the following keys in /usr/share/glib-2.0/schemas/org.pantheon.terminal.gschema.xml and changed default to equal false, and yet I am still getting the same behavior.

    <key name="follow-last-tab" type="b">
    <default>false</default>
    <summary>Open last active tab path on new tab.</summary>
    <description>Defines whether a new tab should have the path of the last active tab.</description>
    </key>
    <key name="remember-tabs" type="b">
    <default>false</default>
    <summary>Defines whether the terminal should remember tabs.</summary>
    <description>Defines whether the terminal should remember the last open tabs.</description>
    </key>

any help would be appreciated.

6

You must actually change those keys in gsettings not in the gschema. So use for example the terminal with: gsettings set org.pantheon.terminal.settings follow-last-tab false

  • Much better solution! – Carl Löndahl Jan 12 '16 at 10:20
  • Interestingly, I went into [Configuator] (quassy.github.io/elementary-apps/Configurator), navigated to org>pantheon>terminal>settings.... and the "follow-last-tab" and "remember-tabs" keys were already set to false. However, using gsettings in command line worked fine. – Beorn Morder Jan 12 '16 at 10:29
3

A work-around: add cd ~ to your bashrc file.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.