3

Anyway tried to install the latest mongodb installation using the ubuntu tutorial? I tried it before but can't seem to replicate it. I'm getting this error when doing sudo apt-get update

W: GPG error: http://repo.mongodb.org trusty/mongodb-org/3.2 Release: The following signatures were invalid: BADSIG D68FA50FEA312927 MongoDB 3.2 Release Signing Key

0

The error message is not indicating that the public key is missing but rather that the signature is bad.

I too have same warning message, I have tried all solutions provided here, but nothing works.

The possible workaround is Install from tarball:

I am just copy & pasting commands here from above link.

  • Download the binary files for the desired release of MongoDB.

    curl -O https://fastdl.mongodb.org/linux/mongodb-linux-x86_64-3.2.0.tgz
    
  • Extract the files from the downloaded archive.

    tar -zxvf mongodb-linux-x86_64-3.2.0.tgz
    
  • Copy the extracted archive to the target directory.

    mkdir -p mongodb
    cp -R -n mongodb-linux-x86_64-3.2.0/ mongodb
    

Note:

Don't just add keys from error messages. Only add keys you trust. Because any repository with this key, would be able to install any package without warning.

EDIT:

mongodb 3.0 has no warning messages,

sudo apt-key adv --keyserver hkp://keyserver.ubuntu.com:80 --recv 7F0CEB10
echo "deb http://repo.mongodb.org/apt/ubuntu trusty/mongodb-org/3.0 multiverse" | sudo tee /etc/apt/sources.list.d/mongodb-org-3.0.list
sudo apt-get update
  • The given key was from mongodb official documentation so I trusted it. But still it gives the error message and Installing tarball is a bit lame. – mateeyow Jan 12 '16 at 8:53
  • yes, I too added key but still error persist. Install from tarball is present alternative – Ravan Jan 12 '16 at 9:00
  • @mateeyow please see my edit. – Ravan Jan 12 '16 at 9:10
  • 2
    Yup, thanks! It seems to be an error on their end. – mateeyow Jan 12 '16 at 9:10
  • @Raven I've just submitted an issue regarding the GPG key and I think they fixed it already. Can't try it now because I need my documents but I'll be happy if you try it out yourself. :) – mateeyow Jan 13 '16 at 1:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.