8

I have been having some issues installing Nvidia graphics drivers, I have tried many different things including things I've seen in other stack questions.

I tried:

  • Installing manually using the .run from their website, following a gist
  • Using the ppa's found here

Things that I have ended up doing:

  • Blacklisted nouveau in /etc/modprobe.d/blacklist-nouveau.conf
  • Ended up removing nouveau per suggestion found somewhere else to no change

Where I'm at:

  • Black screen
  • Occasionally stuck at a white 'e' (elementary icon)
  • /var/log/lightdm/lightdm.log final lines are giving

[+0.00s] DEBUG: Seat: Failed to find session configuration default [+0.00s] DEBUG: Seat: Failed to create greeter session

Any help would be helpful, thanks!

  • Possible duplicate of How to reset graphic drivers from command line – Ravan Jan 11 '16 at 2:21
  • Very similar, however, I have done all of that and am currently running 352 as suggest for my card (GTX 750) – Samuel Jan 11 '16 at 4:02
  • If you couldn't successfully install and use the NVidia drivers NEVER remove nouveau. I suggest reinstalling nouveau. – Eduardo Cola Jan 11 '16 at 13:13
  • What would be the point of going back to nouveau? Giving up on the nvidia drivers? EDIT: my linux background is 100% server, never had a gui in my life, new to using the graphics drivers on linux – Samuel Jan 11 '16 at 19:27
  • I'd install that noveau driver again and also synaptic. Then open synaptic and just check nvidia-352 and it'll do everything by itself – Maccer Jun 17 '16 at 19:15
3

You need to install the nvidia-352 package and you need to disable nouveau (open source driver for Nvidia graphics) in GRUB.

  1. Press CTRL + Alt + F1 and log in by entering a username and password. CAUTION: this will deactivate elementary OS's graphical interface, leaving you with a command line, so read this entire set of instructions first.
  2. Execute following commands

    sudo apt-get update
    sudo apt-get install nvidia-352
    sudo reboot
    
  3. The computer will restart. When you get to the GRUB loader screen, select elementary OS and press the E key to edit that boot command.

  4. Add nouveau.modeset=0 to the end of the linux line.
  5. Press F10 to save and boot.
  • I did these steps and now I have a blinking cursor when I boot. Is this graphics? – Michael Fulton May 11 '18 at 21:41
  • Press CTRL + Alt + F1 and log in by entering a username and password, then enter command nvidia-xconfig – Laxmikant Mokadam Oct 29 '18 at 2:42
  • Right, that's the first step. On the second step it requires a reboot. After reboot, I had only a blinking cursor and Ctrl alt f1, along with everything else, did nothing. It's like the operating system, Grub and everything else was gone. I just installed Windows at that point. – Michael Fulton Oct 29 '18 at 2:45
0

You can install the additional hardware tool that ships by default in Ubuntu, and this will configure your system with the latest versions of the drivers you need at the click of a button.

See: Loki, additional hardware

0

In Elementary OS 4.1, there is a AppCenter app.

In the AppCenter, there is a "Nvidia X Server Settings" app. Install that and reboot.

After rebooting, there will be a driver update in the AppCenter for "nvidia-375". At time of writing, nvidia-375 is the latest long term driver. Install nvidia-375 and reboot. The computer will be using the proprietary Nvidia driver now.

Prior to this, you could see that the nouveau driver was being used via terminal: lshw -c video | grep 'configuration' which shows driver=nouveau latency=0. After updating, it will show driver=nvidia latency=0

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.