1

monitor: ViewSonic VX2460h

GPU: Nvidia GT650M

NVIDIA Driver Version: 355.11

Output of xrandr

Screen 0: minimum 8 x 8, current 3409 x 1080, maximum 16384 x 16384
VGA-0 disconnected (normal left inverted right x axis y axis)
LVDS-0 connected primary 1920x1080+0+0 (normal left inverted right x axis y axis) 345mm x 194mm
  1920x1080      59.9*+
HDMI-0 connected 1024x768+2385+203 (normal left inverted right x axis y axis) 0mm x 0mm
  1024x768       60.0*+
 1360x768       60.0     59.8  
 1152x864       60.0  
 800x600        72.2     60.3     56.2  
 680x384        60.0     59.8  
 640x480        59.9  
 512x384        60.0  
 400x300        72.2  
 320x240        60.1  

~$ cvt 1920 1080
-# 1920x1080 59.96 Hz (CVT 2.07M9) hsync: 67.16 kHz; pclk: 173.00 MHz
Modeline "1920x1080_60.00"  173.00  1920 2048 2248 2576  1080 1083 1088 1120 -hsync +vsync

~$ xrandr --newmode 1920x1080 173.00  1920 2048 2248 2576  1080 1083 1088 1120 -hsync +vsync
 X Error of failed request:  BadName (named color or font does not exist)
 Major opcode of failed request:  140 (RANDR)
 Minor opcode of failed request:  16 (RRCreateMode)
 Serial number of failed request:  35
 Current serial number in output stream:  35
1

Seems to me that your xrandr --newmode syntax is incomplete (without the enclosing quotes).

Also, you should check this answer to make sure you're following the steps correctly, and you're giving xrandr the parameters it needs.

Finally, remember that in order to make xrandr modes permanent, you should create a script to add them at boot time.

  • I success for the newmode option, but the addmode is still the same. – JulianLai Jan 8 '16 at 12:53
  • ~$ sudo xrandr --addmode HDMI-0 "1920x1080_60.00" – JulianLai Jan 8 '16 at 12:53
  • X Error of failed request: BadMatch (invalid parameter attributes) – JulianLai Jan 8 '16 at 12:54
  • Major opcode of failed request: 140 (RANDR) – JulianLai Jan 8 '16 at 12:54
  • Minor opcode of failed request: 18 (RRAddOutputMode) – JulianLai Jan 8 '16 at 12:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.