4

I cannot put any icons or right click on the desktop in Elementary Freya. How can I enable that?

marked as duplicate by Ravan, Daniel Foré, bigbang, Community Jan 6 '16 at 17:25

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • By default the desktop in elementary OS is disable. Have you enabled it? – shrestha_aj Jan 5 '16 at 18:00
5

To enable the desktop

Step 1:
Install Nautilus dconf-tools:

sudo apt-get update
sudo apt-get install --no-install-recommends nautilus dconf-tools

Step 2:
Open dconf-editor and go to, org > gnome > nautilus > desktop and tick on any option which you want to view on desktop. enter image description here

Step 3:
Then go to, org > pantheon > desktop > cerbere and add 'nautilus -n' entry as shown below.

['wingpanel', 'plank', 'slingshot-launcher --silent', 'nautilus -n']

enter image description here

Step 4:
Open Terminal and type following command, nautilus -n

Step 5:
Go to dconf-tools again and go to, org > gnome > desktop > background and tick on show-desktop-icons box enter image description here

If there is any problem, simply logout and login again.

  • nice answer!, this seems to be a duplicate question, doesn't it? Please use flag :) – Ravan Jan 6 '16 at 2:46
  • The other answer has link in it. This has more detailed answer so we can flag the new ones as duplicate and link it to this answer. – shrestha_aj Jan 6 '16 at 10:34
  • nope, see here, your answer is same as this one except screenshots. – Ravan Jan 6 '16 at 11:01

Not the answer you're looking for? Browse other questions tagged or ask your own question.