I have installed nemo file manager and wanted to enable desktop icons.

As you can see on the screenshot the desktop is looking like a normal window.

So how to fix that? I'm running elementary OS Freya.

nemo as desktop manager screenshot

  • Looks like your desktop is enable. Can you be a bit clearer of what you want to achieve? – shrestha_aj Jan 4 '16 at 16:53
  • 3
    I thought it's clear! you can see that the desktop is looking like a normal window and not full screen – Naheel Jan 4 '16 at 16:54

There is a decision by elementary os to enable client-side decorations which affect windows not aware of that. See GTK+ Incorrect Window Size

This is tested to work for Freya in VBox:

GTK_CSD="" nemo

So modify exec line in the autostart file /etc/xdg/autostart/nemo-autostart.desktop , as below:

Exec=sh -c "GTK_CSD=\"\" nemo -n"


Exec=sh -c "GTK_CSD='' nemo -n"

enter image description here

  • 1
    wonderful! it worked like charm! but I changed the desktop file to: sh -c "GTK_CSD="" nemo" %U and autostart desktop: sh -c "killall nemo && GTK_CSD="" nemo" and still getting that window on login – Naheel Jan 6 '16 at 15:40
  • @Naheel, good, I will check where the cmd of nemo for session start. So we can change it without that kill cmd. – user.dz Jan 6 '16 at 15:57
  • @Naheel, your issue is with the "" escaping, see my edit, please if it works for you, check the accept flag, see elementaryos.stackexchange.com/help/someone-answers – user.dz Jan 6 '16 at 23:54
  1. Go to:

  2. For this you need administrator privilege, and change:

    Exec = nemo --no-desktop %U
  3. Also check in ~/.local/share/applications/ folder. If there is nemo file, make the same changes.

  • no difference at all – Naheel Jan 4 '16 at 17:15
  • 1
    You can try to run this command in your terminal: gsettings set org.nemo.desktop show-desktop-icons false – shrestha_aj Jan 4 '16 at 20:10

I am new to Elementary and wanted my beloved OS X-Desktop back, so I tried this. Sadly, changing the nemo-autostart.desktop as mentioned above, somehow does not work for me. Launching it with GTK_CSD="" nemo from the terminal works fine though. Do you have any suggestions?


The same in Loki:

Inspired by a comment by shrestha-aj under other answer:

gsettings set org.nemo.desktop show-desktop-icons false

In Dconf Editor:

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.