0

I am trying to install Lazarus. I tried the one in the software center but it is old and complains about a missing directory. So I downloaded the latest .deb file and tried to install that but it says it can't satisfy the dependencies. I have no problems install it on Ubuntu, but I hate the Unity DE. Please help. I like Elementary, but this is driving me crazy.

  • 1
    Welcome to Elementary OS (SE network), :) How we can help with such very short description you gave. Could you add more details: the commands you run, their full output, from where you downloaded the last deb package? – user.dz Jan 3 '16 at 8:20
  • Most notably, please post exactly what .deb you downloaded and from where, and try installing it with sudo dpkg -i lazarus.deb – Lewis Goddard Jan 3 '16 at 8:50
1

.deb installation worked for me, and this is how I've done it:

Visited the Lazarus website, went to downloads (either 32bit or 64bit Linux), and then downloaded all three (as hinted) files that were there, and installed them via Software Center. Note that the order of my installs were:

  1. FPC-src package
  2. FPC package
  3. Lazarus package

For people new to Ubuntu that don't understand why didn't we just download it directly from Software Center: Most of the packages in Software Center are outdated because 0.3 Freya is based on Ubuntu 14.04 (two years old now), and the packages in it are just as old. Packages will be refreshed when the next version of elementary OS launches, presumably based on Ubuntu 16.04.

0

sorry for taking so long to get back. My email was filtering out these.. Anyway, I was able to get around it by installing CodeTyphon. Which installs from source code, but provides a handy script to do it with. With Lazarus, it would complain about not being able to resolve a dependency.

0

if you are running Elementary OS 0.4 Loki (64-Bit) you can follow this instructions to get a working IDE and compilation routines:

  1. Download the amd64 version from the official lazarus website (http://www.lazarus-ide.org/index.php?page=downloads)

    • fpc_xxxxxx_amd64.deb
    • fpc-src_xxxxxx_amd64.deb
    • lazarus-project_xxxxxx_amd64.deb
  2. Install the deb packages in this order: fpc, fpc-src, lazarus

    • sudo apt install ./fpc_xxxxxx_amd64.deb
    • sudo apt install ./fpc-src_xxxxxx_amd64.deb
    • sudo apt install ./lazarus_xxxxxx_amd64.deb
  3. From here, after installed the packages, the IDE should start normally(from de linux main menu or by teminal), but maybe will have issues to compile. Continue bellow to solve dependencies of compilation

    • sudo apt-get install libgdk-pixbuf2.0-dev libcairo2-dev libpango1.0-dev libatk1.0-dev libghc-x11-dev libgtk2.0-dev
  4. After installing the dependencies, your lazarus ide should be running and compiling fine.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.