0

Black screen after boot after changing adding something to conf folder.

I added a xorg.conf.d file called "50-gamma.conf" which contains:

display-setup-script=xrandr --output eDP1 -- gamma 1:0.93:1

Then I restarted my computer and it boots to a black screen. What happened?

I followed the instruction of the second answer from:

https://askubuntu.com/questions/633455/xrandr-not-saving-settings-permanetly-in-ubuntu-14-04

  • I can confirm this – Ravan Jan 1 '16 at 1:29
  • delete the .conf which you have created, it will solve – Ravan Jan 1 '16 at 1:33
  • are you able to delete the .conf file? – Ravan Jan 1 '16 at 2:39
  • Nope, I had to reinstall. I don't have access to terminal at black screen. – Dobob Jan 1 '16 at 2:54
  • 1
    I have already reinstalled, so I don't have to do it anymore. But thanks though, I can use this in the future. – Dobob Jan 1 '16 at 7:39
1

I am going to provide you a solution to get back from black screen. The black screen is caused by the .conf file that you have created. First remove it, it will solve the issue.

Note : I have tested this solution

Step-1: Restart system. Go to advanced options --> select recovery mode.

step-2: Now using the arrow keys scroll down to root and then hit enter

Imgur

Step-3: Run the following commands to remove:

mount -rw -o remount /
rm -rf /usr/share/X11/xorg.conf.d/50-gamma.conf 
reboot

Explanation: The first command changes permission, second remove file you have created.

As a side note: If I follow instruction from blog/web, is that always safe?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.