1

My laptop is thinkpad T450s and there is very bad screen tearing when I move windows around or when I watch videos. My CPU is Intel HD 5500 with integrated graphics(core i5).

I looked around but I only found a solution for Ubuntu. I found same question and this is the answer.

I am not sure if that can be used for elementary OS. It didn't fix anything. Is there a solution for screen tearing on elementary OS?

I have also tried this video and it didn't work.

EDIT: It does work, you just need to restart, which I forgot to do. See solution below.

3
  • : Please drop at chat.stackexchange.com/rooms/33627/ravan-and-dobo
    – Ravan
    Commented Dec 30, 2015 at 13:48
  • I just set the video output as OpenGL, and the problem was solved. (intel HD4600)
    – JulianLai
    Commented Dec 30, 2015 at 17:09
  • Did not solve at all, tried to reboot and desktop manager just won't start.
    – DrG95
    Commented Feb 26, 2017 at 6:08

2 Answers 2

1

It turns out I just had to restart the computer for it to take effect(of course!). Type the following into the terminal to get rid of screen tearing for intel CPU/integrated graphics. In this case I tested it for intel HD graphics 5500 on my Lenovo Thinkpad T450s.

sudo mkdir /etc/X11/xorg.conf.d/
echo -e 'Section "Device" \n Identifier "Intel Graphics" \n Driver "Intel" \n Option "TearFree" "true" \nEndSection' | sudo tee /etc/X11/xorg.conf.d/20-intel.conf

The file "/etc/X11/xorg.conf.d/20-intel.conf" should contain:

Section "Device"
Identifier  "Intel Graphics"
Driver      "Intel"
Option      "TearFree"    "true"
EndSection
1
  • Thanks - This also worked for me in Ubuntu 16.10 beta 2, though I did have to create the file in /usr/share/X11/xorg.conf.d
    – user6849
    Commented Oct 9, 2016 at 18:18
0

You could also try. Helped with graphical abnormalities for me on an Intel 7200U with integrated graphics.

sudo apt-get remove --purge xserver-xorg

Not the answer you're looking for? Browse other questions tagged or ask your own question.