-1

I am using elementary OS freya 0.3.2

lsb_release -a
No LSB modules are available.
Distributor ID: elementary OS
Description:    elementary OS Freya
Release:    0.3.2
Codename:   freya

I have downloaded Opera .deb from their official site. When I tried from software center:

Imgur

From terminal:

ravan@ravan:~/Downloads$ software-center opera-stable_34.0.2036.25_amd64.deb

** (software-center:10987): WARNING **: Couldn't connect to accessibility bus: Failed to connect to socket /tmp/dbus-C4cCKJjSeX: Connection refused
2015-12-26 13:40:04,684 - softwarecenter.ui.gtk3.app - INFO - setting up proxy 'None'
2015-12-26 13:40:05,054 - softwarecenter.backend.reviews - WARNING - Could not get usefulness from server, no username in config file
2015-12-26 13:40:05,056 - softwarecenter.plugin - INFO - activating plugin '<module 'webapps_activation' from '/usr/share/software-center/softwarecenter/plugins/webapps_activation.pyc'>'
2015-12-26 13:40:05,109 - softwarecenter.db.pkginfo_impl.aptcache - INFO - aptcache.open()
2015-12-26 13:40:05,595 - softwarecenter.backend.reviews - WARNING - error creating bsddb: '(22, 'Invalid argument -- BDB0054 illegal flag combination specified to DB_ENV->open')' (corrupted?)
2015-12-26 13:40:05,595 - softwarecenter.backend.reviews - ERROR - trying to repair DB failed
Traceback (most recent call last):
  File "/usr/share/software-center/softwarecenter/backend/reviews/__init__.py", line 358, in _save_review_stats_cache_blocking
self._dump_bsddbm_for_unity(outfile, outdir)
  File "/usr/share/software-center/softwarecenter/backend/reviews/__init__.py", line 377, in _dump_bsddbm_for_unity
0600)
DBInvalidArgError: (22, 'Invalid argument -- BDB0054 illegal flag combination specified to DB_ENV->open')
/usr/lib/python2.7/dist-packages/gi/overrides/GLib.py:535: Warning: Source ID 61 was not found when attempting to remove it
 return super(MainContext, self).iteration(may_block)
2015-12-26 13:40:07,099 - softwarecenter.ui.gtk3.views.lobbyview - WARNING - skipping exhibit for: 'u'leadwerks\r\nleadwerks-indie'' not available
/usr/share/software-center/softwarecenter/ui/gtk3/views/appdetailsview.py:2030: Warning: Source ID 135 was not found when attempting to remove it
  Gtk.main_iteration()
2015-12-26 13:40:07,224 - softwarecenter.fixme - WARNING - logs to the root logger: '('/usr/lib/python2.7/dist-packages/dbus/connection.py', 589, 'call_async')'
2015-12-26 13:40:07,223 - dbus.connection - ERROR - Unable to set arguments ([None], [''], [''], [''], [''], ['']) according to signature None: <type 'exceptions.TypeError'>: Don't know which D-Bus type to use to encode type "NoneType"
Traceback (most recent call last):
  File "/usr/lib/python2.7/dist-packages/defer/__init__.py", line 489, in _inline_callbacks
result = gen.send(result)
  File "/usr/lib/python2.7/dist-packages/aptdaemon/client.py", line 1626, in _run_transaction_helper
timeout=_APTDAEMON_DBUS_TIMEOUT)
  File "/usr/lib/python2.7/dist-packages/dbus/proxies.py", line 137, in __call__
**keywords)
  File "/usr/lib/python2.7/dist-packages/dbus/connection.py", line 584, in call_async
    message.append(signature=signature, *args)
TypeError: Don't know which D-Bus type to use to encode type "NoneType"
Traceback (most recent call last):
  File "/usr/lib/python2.7/dist-packages/defer/__init__.py", line 489, in _inline_callbacks
  result = gen.send(result)
  File "/usr/lib/python2.7/dist-packages/aptdaemon/client.py", line 1626, in _run_transaction_helper
timeout=_APTDAEMON_DBUS_TIMEOUT)
  File "/usr/lib/python2.7/dist-packages/dbus/proxies.py", line 137, in __call__
**keywords)
  File "/usr/lib/python2.7/dist-packages/dbus/connection.py", line 584, in call_async
message.append(signature=signature, *args)
  TypeError: Don't know which D-Bus type to use to encode type "NoneType"
2015-12-26 13:40:07,225 - softwarecenter.db.pkginfo_impl.aptcache - ERROR - simulate failed
Traceback (most recent call last):
  File "/usr/lib/python2.7/dist-packages/aptdaemon/client.py", line 1591, in on_error
    error.raise_exception()
  File "/usr/lib/python2.7/dist-packages/defer/__init__.py", line 489, in _inline_callbacks
  result = gen.send(result)
  File "/usr/lib/python2.7/dist-packages/aptdaemon/client.py", line 1626, in _run_transaction_helper
    timeout=_APTDAEMON_DBUS_TIMEOUT)
 File "/usr/lib/python2.7/dist-packages/dbus/proxies.py", line 137, in __call__
**keywords)
 File "/usr/lib/python2.7/dist-packages/dbus/connection.py", line 584, in call_async
   message.append(signature=signature, *args)
 TypeError: Don't know which D-Bus type to use to encode type "NoneType"
 2015-12-26 13:40:07,341 - softwarecenter.backend.spawn_helper - WARNING - exit code 1 from helper for '['/usr/share/software-center/piston_generic_helper.py', '--datadir', '/usr/share/software-center/', 'SoftwareCenterRecommenderAPI', 'recommend_app', '{"pkgname": null}']'
2015-12-26 13:40:07,341 - softwarecenter.backend.spawn_helper - WARNING - got error from helper: 'ERROR:__main__:urclient_apps
Traceback (most recent call last):
 File "/usr/share/software-center/piston_generic_helper.py", line 147, in <module>
  piston_reply = f(**kwargs)
 File "/usr/lib/python2.7/dist-packages/piston_mini_client/validators.py", line 41, in wrapper
   "Argument '%s' must be a string" % varname)
 ValidationException: Argument 'pkgname' must be a string

  2015-12-26 13:40:07,342 - softwarecenter.db.categories - WARNING - Error while accessing the recommender service: ERROR:__main__:urclient_apps
Traceback (most recent call last):
  File "/usr/share/software-center/piston_generic_helper.py", line 147, in <module>
  piston_reply = f(**kwargs)
  File "/usr/lib/python2.7/dist-packages/piston_mini_client/validators.py", line 41, in wrapper
   "Argument '%s' must be a string" % varname)
ValidationException: Argument 'pkgname' must be a string

2015-12-26 13:40:07,342 - softwarecenter.ui.gtk3.widgets.recommendations - WARNING - Error while accessing the recommender agent: ERROR:__main__:urclient_apps
Traceback (most recent call last):
 File "/usr/share/software-center/piston_generic_helper.py", line 147, in <module>
 piston_reply = f(**kwargs)
 File "/usr/lib/python2.7/dist-packages/piston_mini_client/validators.py", line 41, in wrapper
  "Argument '%s' must be a string" % varname)
ValidationException: Argument 'pkgname' must be a string

/usr/bin/software-center:184: Warning: Source ID 215 was not found when attempting to remove it
 Gtk.main()
/usr/bin/software-center:184: Warning: Source ID 213 was not found when attempting to remove it
  Gtk.main()
/usr/lib/python2.7/dist-packages/gi/overrides/GLib.py:535: Warning: Source ID 20 was not found when attempting to remove it
 return super(MainContext, self).iteration(may_block)
2015-12-26 13:40:12,125 - softwarecenter.db.utils - INFO - software-center-agent finished with status 0

ravan@ravan:~/Downloads$ sudo dpkg -i opera-stable_34.0.2036.25_amd64.deb
[sudo] password for ravan: 
Selecting previously unselected package opera-stable.
(Reading database ... 217479 files and directories currently installed.)
Preparing to unpack opera-stable_34.0.2036.25_amd64.deb ...
Unpacking opera-stable (34.0.2036.25) ...
dpkg-deb (subprocess): cannot copy archive member from 'opera-stable_34.0.2036.25_amd64.deb' to decompressor pipe: unexpected end of file or stream
dpkg-deb (subprocess): decompressing archive member: lzma error: unexpected end of input
dpkg-deb: error: subprocess <decompress> returned error exit status 2
dpkg: error processing archive opera-stable_34.0.2036.25_amd64.deb (--install):
cannot copy extracted data for './usr/lib/x86_64-linux-gnu/opera/opera.pak' to '/usr/lib/x86_64-linux-gnu/opera/opera.pak.dpkg-new': unexpected end of file or stream
Processing triggers for menu (2.1.46ubuntu1) ...
Errors were encountered while processing:
  opera-stable_34.0.2036.25_amd64.deb
  • JFTR: I was able to install the same version using software center without problem (Freya 0.3.2 as well). – ounos Dec 26 '15 at 19:01
0

It seems there is a problem with the download and the file got corrupted. I have installed it manually using Ubuntu documentation.

I have manually added opera apt-repository:

sudo add-apt-repository 'deb https://deb.opera.com/opera-stable/ stable non-free'
wget -qO- https://deb.opera.com/archive.key | sudo apt-key add -

Then installed opera,

sudo apt-get update
sudo apt-get install opera-stable

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.