1

OK, so I messed around with PulseAudio and purged all of it. Now my regular sound settings do not work anymore. neither can I turn up and down the volume with the respective keys, nor do the sound settings show any devices (neither input nor output). The sound symbol does not show in the menu bar anymore either. I can hear sound though.

I guess I accidentally uninstalled a package that is needed. Does anybody know which packages I have to reinstall?

2
  • 1
    Why did you decide to purge PulseAudio? It's a terrible decision to remove packages which purpose you do not understand. Did something point you that way?
    – embik
    Dec 19, 2015 at 17:22
  • Because I'm an idiot :) I was trying to stream to Airtunes and it didn't work so I was impatient and thought a reinstall would be a good idea (which it was not). Lesson learned ;)
    – deesnook
    Dec 20, 2015 at 18:42

3 Answers 3

2

PulseAudio is the sound server. It is necessary for all of the functions that are now broken on your system. You need to reinstall it.

6
  • Thank you - I did a clean reinstall of the OS to be sure it worked. But now it gets a little weird: Sound is working normally; however there is still no symbol in the menu bar. BUT there is a little space between the symbols for language and wifi, and when I click there the regular drop down menu appears and I can e.g. control Music or Banshee - but the volume bar is greyed out and I cannot change the volume. I then installed pavucontrol and when I try to open it there is an error message that reads: "Fatal Error: Unable to connect to PulseAudio: OK" Any ideas? and thank you again!
    – deesnook
    Dec 20, 2015 at 22:00
  • Also, in the system settings there aren't any sound devices showing, neither input nor output
    – deesnook
    Dec 20, 2015 at 22:16
  • Controlling the volume with alsamixer works though
    – deesnook
    Dec 20, 2015 at 22:18
  • The sound symbol in the menu bar is back because I turned it on using dconf (com/canonical/indicator/sound/visible). Doesn't change the problem though, the volume control is greyed out and I cannot use the volume +/- keys on the keyboard either
    – deesnook
    Dec 20, 2015 at 22:31
  • @luett Since it seems you're having a new problem unrelated to this question, can you please open a new question? Dec 21, 2015 at 2:15
1

After reinstalling the system (I suppose just the pulseaudio packages would have done too) the problem was that the config files in my home folder - which I hadn't deleted because I didn't format my home folder - were apparently corrupted and caused a malfunction. Thus, I deleted

~/.config/pulse

~/.gconf/system/pulseaudio

and restarted the system. And voilà, everything works again. The sound button in the menu bar is back, and I can use keys to control the volume.

0

Tried to use pulse audio, didnt work so i deleted it like the first guy, my headphones, speakers and usb dac/amp (IKKO ITM01s) died, then installed QasMixer and the headphone jack and speakers work, but not my usb dac/amp, everything was fixed when I installed pipewire with this guide and regained control from the sound panel

Add ppa for latest build

sudo add-apt-repository ppa:pipewire-debian/pipewire-upstream

Update

sudo apt update

Install components

sudo apt install gstreamer1.0-pipewire pipewire-media-session libspa-0.2-bluetooth libspa-0.2-jack pipewire pipewire-audio-client-libraries

If you get unmet dependencies, you can run:

sudo apt --fix-broken install

Then re-run

sudo apt install gstreamer1.0-pipewire pipewire-media-session libspa-0.2-bluetooth libspa-0.2-jack pipewire pipewire-audio-client-libraries

Reload new services

systemctl --user daemon-reload

Disable PulseAudio service

systemctl --user --now disable pulseaudio.service pulseaudio.socket

If you update from previous version of PopOS

systemctl --user mask pulseaudio

Enable Pipewire services

systemctl --user --now enable pipewire pipewire-pulse

Enable Pipewire media session

systemctl --user --now enable pipewire-media-session.service

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.