0

I have an older Apple Airport Express device and would like to stream my music to it using Banshee. I've followed these instructions:

https://blogs.gnome.org/danni/2009/10/22/streaming-to-airtunes-airport-express-with-pulseaudio/

and it basically works, the AEX is detected and there's music coming out of my speakers. :) However, the stream constantly stutters, so I thought I'd change the buffer size. I found and followed these instructions and edited the /etc/pulse/daemon.conf file:

http://forums.linuxmint.com/viewtopic.php?f=42&t=44862

But alas, it still doesn't work. When I calculate my buffer size according to the mentioned article,

default-fragments = 2

default-fragment-size-msec = 23

it is still stuttering. I then augmented the default fragment size to 100, 200, 300 etc. up to 500 msec. The result is, it gets better. At around 350 msec and more the stream has some latency, but basically works without any drop-outs - but only for a couple of minutes, then the stuttering returns. Also, when I skip to the next track it stutters immediately.

The third comment (by theAntiBob) to the article in the Mint Forum mentions that changing the buffer size alone won't do unless you change the timer-based scheduling to being disabled in /etc/pulse/default.pa by adding tsched=0 to the end of the line load-module module-udev-detect. However, I tried and that doesn't seem to work either resp. to have any effect.

Any ideas?

0

It looks like the cause of the problem is not the buffer size, but rather the network manager, which apparently intermittently has the WiFi device scan for networks. This seems to interrupt the stream, so independently of the buffer size little parts of the stream are missing, which produces the stuttering effect.

I was able to fix it by setting the BSSID of my WiFi connection. It's fairly easy, all you have to do is go to the settings of your connection. There's a pull-down menu named "BSSID" which is usually empty, but if you open it it offers you a string of characters. Pick that one, and it'll work fine.

Enjoy your music and rock on!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.