1

I have a PC with elementary OS only and after loading screen and elementary logo there is just a black screen instead of login screen. My keyboard acts like it's unplugged, it doesn't respond to num lock or scroll lock or caps lock button, all diodes are off. HDD led in my pc doesn't show any hard drive actions. When I boot up with the Linux kernel 3.19.0.39 everything works just fine. How can I diagnose what's going on, or how can I try to fix the newer kernel?

  • boot to 3.19.0.41 recovery mode and select resume normal reboot and let me know ;) – Ravan Dec 18 '15 at 14:57
  • I have a black screen in recovery mode too, but with blinking underscore character in the top-left corner – siwers Dec 18 '15 at 15:08
  • Ok i figured it out. NVIDIA drivers was causing this problem. Reinstallation didn't help, but remove with --purge flag and new installation did. Thanks for help anyway – siwers Dec 18 '15 at 15:29
  • Please post it as answer :) – Ravan Dec 18 '15 at 15:30
  • See here if useful :) – Ravan Dec 18 '15 at 15:31
2

NVIDIA drivers were causing the problem. I removed drivers completely with --purge flag and then installed current drivers again and now everything works.
Here's how to do this: https://askubuntu.com/questions/41681/blank-screen-after-installing-nvidia-restricted-driver

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.