6

I read THIS answer that was really good on how to change the keyboard layout with Left Ctrl + Left Shift, but when I use

Ctrl Shift C (to copy on terminals)

and Ctrl Shift V (to paste on terminals)

the keyboard layout changes and I cannot perform the copy/paste action. In Elementary Luna, which I had previously, It would only change the Layout ON KEY UP. Hence, it would not conflict with Ctrl + Shift + (whatever key). And on Freya, according to that answer, it is ON KEY DOWN.

Is there any chance to make it work like Luna, and the key combination Left Shift + Left Ctrl take effect only ON KEY UP?

3

The problem with using modifiers (shift, ctrl, alt, super) is that they are modifiers, and not designed to actually change something themselves. I would suggest that a far easier fix would be to simply assign the shortcut to , Ctrl + Shift + L or something similar. Basically, include a non-modifier key in all your shortcuts.

  • 1
    Thing is: It worked on Elementary Luna. I'd like it to behave the same way. It is possible. – Aleksandrus Dec 19 '15 at 22:30
  • It also works in Ubuntu 16.04 LTS but doesn't work in Elementary Loki. So using alternative shortcuts is not a solution. I prefer Ctrl+Shift. – Ezze Feb 12 '18 at 10:12
2

The problem is that shortcut works on key press than key release. You are using Ctrl + Shift to language change. The linked post also have option Shift + Alt.

gsettings set org.pantheon.desktop.gala.keybindings switch-input-source "['<Alt>Shift_L', '<Alt>Shift_R', '<Shift>Alt_L', '<Shift>Alt_R']"

Use it and you can avoid conflict.

  • I also prefer to use Ctrl+Shift over Shift+Alt. So using Shift+Alt instead doesn't answer the question. – Ezze Feb 12 '18 at 10:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.